Problems with service after travelling in US

  • 1
  • Question
  • Updated 4 years ago
  • Answered
I live in a border town to the US. Everything was fine with my koodoo service when I went over. Since coming back, my phone continues to show that I am in the US. This has happened before and the problem either corrected itself after a little while or the phone would recognize that I was back in Canada after I would reboot it. It's been several hours now and I've rebooted the phone but the service bar is still showing a US carrier. I turned off roaming while in the US but now I can't make any calls or texts without US roaming.
Photo of Melissa Lochhead

Melissa Lochhead

  • 118 Points 100 badge 2x thumb
  • frustrated

Posted 4 years ago

  • 1
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Goto your network setting and switch from automatic network selection to manual network selection

Your phone will perform a scan which can take up to 2 minutes.

You'll be presented with a list of available carriers

Choose telus or Koodo

If you Go back to the states change it back to automatic
Photo of Melissa Lochhead

Melissa Lochhead

  • 118 Points 100 badge 2x thumb
Thanks for trying to help. I did try this before posting my question and it didn't help. I was able to fix the problem with 3G being turned back on.
Photo of Scott Lougheed

Scott Lougheed

  • 1,402 Points 1k badge 2x thumb
Another, slightly more extreme troubleshooting strategy would be to reset your network settings. It looks like this is tagged with the iPhone tag so I'm assuming that's what you have. You can go
Settings>General>Reset>Reset Network Settings

This should clear any cobwebs that have collected. NOTE that this will also cause the phone to forget any wireless networks you connected to previously so you will need to re-connect and enter your password for any wireless networks you have used.
Photo of Melissa Lochhead

Melissa Lochhead

  • 118 Points 100 badge 2x thumb
I was able to fix my problem by enabling 3G again but I like your idea of clearing the "cobwebs" by resetting the network settings so thanks for sharing.
Photo of Scott Lougheed

Scott Lougheed

  • 1,402 Points 1k badge 2x thumb
Glad you found a solution! Cheers.
Photo of Curtules

Curtules

  • 19,666 Points 10k badge 2x thumb
One thing you can check, if you're still having problems, is to make sure your 3G is enabled.

Settings>Cellular>Enable 3G

Sometimes when you're in the US you find yourself in an area with only 2G coverage. In order to save battery life your phone will automatically turn 3G off because it's not available. However, since Koodo doesn't use a 2G network your service won't work when you get back to Canada.

Unfortunately smartphones aren't smart enough to know if 3G is available when 3G is off.
Photo of Melissa Lochhead

Melissa Lochhead

  • 118 Points 100 badge 2x thumb
You're right. Changing back to 3G fixed the problem.

This conversation is no longer open for comments or replies.