Problem Switching SIM To New Phone

  • 1
  • Question
  • Updated 3 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

My prepaid Nokia got busted and I bought an unlocked AcerZ220 dual SIM phone at Staples. They said it worked on all carriers in Canada but when I put the SIM in it saya NO PHONE instead of saying Koodo like my Nokia did. I cant make or receive calls and the SIM works in my old phone. My account is active-renewed today and if the card is in my old phone it rings when I call it (just cant answer-busted screen) so its not a lack of funds. Ive tried the card in both slots on the Acer
Photo of Tristan Gummow

Tristan Gummow

  • 1,226 Points 1k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Ahmad

Ahmad

  • 96,102 Points 50k badge 2x thumb
There's no reason why it shouldn't work. In network setings, make sure the network type is set to the tight type of network. HSPA or WCDMA
Photo of Mayumi

Mayumi, Mobile Master

  • 115,056 Points 100k badge 2x thumb
Also, restart your phone do a trick most of the times.
Photo of Anna

Anna

  • 6,126 Points 5k badge 2x thumb
Hey Tristan! Were you able to get your phone to start working? Let us know!
Photo of Tristan Gummow

Tristan Gummow

  • 1,226 Points 1k badge 2x thumb
Yeah its working but with a few small issues. For example it doesnt register as Koodo it registers as Telus. And all texts show up as Telus as sender and receiver as opposed to the name of the sender. It shows their # at top of the thread but no name just TELUS lol. 
Photo of Ivan

Ivan, Mobile Master

  • 96,634 Points 50k badge 2x thumb
Sometimes unlocked phones will display TELUS instead of Koodo. That's no problem, as TELUS is Koodo's parent company and they all use the same network.

For your contact's name to display in the thread, it needs to be saved to the phone. It's a dual-SIM phone and they always show what SIM card is being used (i.e. TELUS).
Photo of Tristan Gummow

Tristan Gummow

  • 1,226 Points 1k badge 2x thumb
Its even doing it for people in my SIM contacts and ones imported from my Google account. Its like having 40 friends named Telus lol I saw on another forum a person with the same phone on Rogers having the same thing happen, so I guess its just a quirk of the phone and needs something changed in settings or whatever

Update
Got the SMS fixed had to exit Acer QuickStart and now it uses the default Android messaging app
(Edited)

This conversation is no longer open for comments or replies.