Prepared SIM does not work on NOKIA 510 & 526

  • 1
  • Question
  • Updated 4 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

Hi There,

I have a prepared SIM card that works fine in my Nexus 5, but does not work on neither my dad's NOKIA 526 or my girlfriend's 510, even thought the Koodo website says both devices work in its network.

This is frustrating as I just top up the SIM for my dad. Would you please help to get it work on his device?
Photo of songhonggan

songhonggan

  • 130 Points 100 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Ahmad

Ahmad

  • 96,102 Points 50k badge 2x thumb
You need to make sure the phones are unlocked first. Are they?
Photo of Ivan

Ivan, Mobile Master

  • 96,634 Points 50k badge 2x thumb
Also, make sure that your phones aren't set to 2G network only.
Photo of songhonggan

songhonggan

  • 130 Points 100 badge 2x thumb
Thank you for your reply, Ivan, Ahmad. The phones are unlocked, and the highest speed is set as 3G in setting. It's Win 8 OS.
It could not find the network somehow, the signal bars are grey.
Photo of Ivan

Ivan, Mobile Master

  • 96,634 Points 50k badge 2x thumb
Where did you buy the phones? If they've been reported as lost/stolen in Canada/US, they may be blacklisted and that would explain the situation.
Photo of songhonggan

songhonggan

  • 130 Points 100 badge 2x thumb
My dad bought it in China and used it on daily basis. He brought it with him to Canada last week.

I checked its IMEI on Koodo website that said it's not reported as stolen or lost, and should work in Koodo network. However, after I topping up, it does not work. There is a block sign on the signal bars. But I could see Koodo and Telus as a carriers options for SMS and MMS in the setting though.

This conversation is no longer open for comments or replies.