Prepaid Plan ($45 talk/text/data) w/100Minute add on - Unable to receive incoming calls

  • 1
  • Question
  • Updated 1 year ago
  • Answered
Pretty much exactly as the title states.

Phone is Note 5 - was on Bell network.
Switched my wife's phone (s7) and my phone(note 5) to Koodo last night. Each was done individually and has a separate prepaid account ($45 talk/text/data with free 100 minute addon).

Her phone works great.

My phone will not receive incoming calls. Gives some kind of error like, "...c1. You have reached a number that is not equipped for incoming calls. Please check the number and try again/"

No settings have changed and have also done the following:
- Powered phone off and back on
- Re-seated SIM card
- Mobile data is turned on
- turned WiFi on/off (testing both)
- confirmed not on any data locked modes (full data on with location)
- checked for miscellaneous 'block' settings - nothing available and nothing turned on
- not in airplane mode
- phone displays Koodo as carrier on lock screen (top)
- can't seem to send text either
- Confirmed on my email (confirmations) and have text messages from Koodo saying account is setup and active.
- Checked online Koodo website login and everything says it is fully operational.

Thoughts?
Photo of Clint Hoffman

Clint Hoffman

  • 70 Points
  • frustrated

Posted 1 year ago

  • 1
Photo of Goran

Goran, Mobile Master

  • 97,592 Points 50k badge 2x thumb
I would give it until tomorrow. It's likely that your porting for some reason is taking slightly longer than for your spouse. Let us know if it's still not accepting incoming calls.
Photo of Mayumi

Mayumi, Mobile Master

  • 115,066 Points 100k badge 2x thumb
Also, you can try this.
If your wife's phone works with Koodo's SIM, then can you put your SIM into her phone?
If it doesn't work, then it could be your SIM is faulty.  
If it works, then your SIM is good. So,it could be a case as Goran said.