Prepaid Activation not working at Step 2

  • 2
  • Question
  • Updated 1 year ago
  • Answered
I am trying to activate a new phone on Koodo Prepaid without success all day. At Step 2, nothing happens when I click on 'Continue' for 'Select new phone number'. There is no section displayed on the page to select an area code for the new phone number either. I tried with different browser (Chrome and Microsoft Edge and Safari) on different computers with the same results, I also tried French and English pages with no luck. There is no error messages being displayed either, nothing happens, no hour glass, just nothing.
I tried clicking on the radio button to 'Transfer an existing number' instead, then back to get a new phone number, when I do this, a new section appears to select the local area but it is empty, there is nothing in the pull down list.
Anyone knows what is the issue? Earlier today I have waited 2+ hours for support but I had to leave, so I wasn't able to speak to someone yet at Koodo.
Photo of Mart

Mart

  • 140 Points 100 badge 2x thumb
  • very frustrated

Posted 1 year ago

  • 2
Photo of Mayumi

Mayumi, Mobile Master

  • 112,838 Points 100k badge 2x thumb
At this point, I would send a PM to Koodo on Facebook.They should be able to activate your account for you. You can attach this post too, then they will know what you have done.
Photo of Mart

Mart

  • 140 Points 100 badge 2x thumb
Thanks for your reply Mayumi, I guess I will have to. I just find odd that there is no messages on Koodo saying they have problems with their activation service, I have tried on multiple computers and different browsers.... This is the 4th time I activate a phone with Koodo in the last 6 months but the first prepaid. I must say that although I like the plan and company, their activation process have been hit and miss for 3 of the activation to date for all kind of reasons. Re-considering if I made the right choice with this company. I will have to contact them somehow. thanks again
(Edited)
Photo of David

David, Mobile Master

  • 89,180 Points 50k badge 2x thumb
It appears to be an intermittent problem, so many folks do not encounter it. Seems you are one who has the right combination to find the problem!
Photo of BobTheElectrician

BobTheElectrician

  • 62,064 Points 50k badge 2x thumb
It's an on-and-off glitch with their web site that's been popping up for at least a year. They should have fixed it by now.

But don't chuck your account just because of one web site problem. After all, you don't have to activate every day, and the Facebook response time has been reasonably fast in my experience.
Photo of Sophia

Sophia, Mobile Master

  • 141,558 Points 100k badge 2x thumb
Agree with Bob, Koodo prepaid is one of the best "plans" in Canada for light users - depending on one's needs of course. To chuck it out because of activation problems seems a shame... because once activated, it'll probably serve you well.
Photo of Mart

Mart

  • 140 Points 100 badge 2x thumb
The phone is now activated after speaking with someone at Koodo, the agent confirmed he was experiencing similar issue I had on the Web site but didn't know the cause or had further information about the issue. So for others reading this post in the future, if Koodo doesn't resolve the issue by then, you will likely have to call in to get your phone activated if you have the same symptoms that I had in this post. Regards,