pre-paid U.S. data add on does not work

  • 1
  • Question
  • Updated 1 year ago
I am a pre-paid (pay per use) customer. I recently traveled to the United States and tried to use some U.S add-ons. I purchased a U.S. data add on as well as text and talk add ons. The text and talk add ons appeared to work for me i.e., I could make phone calls and send text messages. However, the data add on was useless as I could not seem to use it.

I was in the Phoenix AZ area and had AT&T coverage on my phone with 3 - 5 bars most of the time. LTE was also available most of the time however, i could not use the data while down there.

Has anyone else had issues with U.S. data add ons? I would like to get this to work, as it stands now Koodo's U.S. data add on is useless.

Note I am running an iPhone 5 and had data roaming turned on the entire time.

thanks,
-reagan
Photo of Reagan Penner

Reagan Penner

  • 80 Points 75 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Bernard

Bernard, Official Rep

  • 75,526 Points 50k badge 2x thumb
Reagan, I don't readily have answer and it is somewhat puzzling given your description. Especially as we had many customers in the US and we see their phones working fine. Now the US is pretty big, you are using US networks not ours, but based on the info above it is still possible for phone settings to be the culprit. Just out of curiosity did wi-fi work?
Photo of Reagan Penner

Reagan Penner

  • 80 Points 75 badge 2x thumb
Yes wi-fi was working for me.


Do you have any instructions on the proper settings for the U.S.?

I tried leaving my Carrier set to automatic in which case the phone picked up AT&T. I also tried turning off automatic and manually selecting AT&T.

Under cellular i tried with LTE on and off.

note I did not change Cellular Data Network settings, i left APN... all set to sp.koodo.com. Is this correct when one is in the U.S.?

I would really like to get this to work. If you have instructions of a how to you can point me at that would be great.

Please advice on what to do. Note I already indicated that I was in Phoenix. I checked the AT&T coverage map for that area and LTE should have been available. The koodo site has no information that I can find to indicate what carrier i should expect to pick up?

Also, my battery would drain quite quickly I assume due to the fact that my phone was constantly searching for a data network?

Your assistance is greatly appreciated.

thanks,
-reagan
Photo of Bernard

Bernard, Official Rep

  • 75,526 Points 50k badge 2x thumb
Everything you've done is right Reagan. You say you manually selected form the available networks and data still didn't work? If yes, I'm somewhat dumbfounded. If you send a private message via Facebook we could try a couple things on our end to see if it changes anything. 
Photo of BobTheElectrician

BobTheElectrician

  • 61,576 Points 50k badge 2x thumb
At one point it seemed AT&T might be having issues with iPhone roaming data in Arizona.

This may not help you, but is offered for Android users in a similar pickle.

My Koodo Note 2 worked fine after a restart. I later bought a refurb unlocked phone and had to manually enter the plain vanilla sp.koodo APN values listed on the Koodo site. Everything works fine for me. See below for settings. Any entry on your phone not listed below should be left blank: