Poor cellular connection for the past week

  • 2
  • Question
  • Updated 2 years ago
  • Answered
I have been receiving a high quality and reliable connection at my home from Koodo for the past 3 years, but last week the connection became poor - there is static and the call breaks up. There are only 2 bars displayed for my phone (which has not changed - Samsung Galaxy 6).
Photo of Paula Loh

Paula Loh

  • 110 Points 100 badge 2x thumb

Posted 2 years ago

  • 2
Photo of Goran

Goran, Mobile Master

  • 90,880 Points 50k badge 2x thumb
Alright let's try to isolate the issue. Restart your phone, toggle airplane mode, pull the Sim card out for a minute then back in. If you're still having issues see if you can put the Sim in another device and another Sim card in your phone. If you're still having issues moving the Sim, try it outside of the neighborhood. Is it only in your house ? Or outside ? When do you start having a good signal again ? If it stays bad then you will need a news Sim card. If its only around your house it could be a tower is down or acting sporadically.
Photo of Paula Loh

Paula Loh

  • 110 Points 100 badge 2x thumb
It is only in my house - when I step outside the signal gets stronger.
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,580 Points 100k badge 2x thumb
Go into your settings, then click mobile networks - network operators - search for networks, it will then search for the closest towers in your area (this can take a minute to search) after the search is complete a lost of carriers will pop up and you will select koodo and then just exit the settings menu.

This has worked for me in the past to fix the weak signal issues so worth a try.
Photo of Paula Loh

Paula Loh

  • 110 Points 100 badge 2x thumb
I tried this, but the signal strength remained the same. I used to receive a weak signal inside my house with other carriers and had to go outside when the phone rang (Rogers, Bell). When I switched to Koodo, the signal was strong inside the house, up until last week.
Photo of rikkster

rikkster, Mobile Master

  • 67,104 Points 50k badge 2x thumb
Try experimenting with a different network mode. If your Galaxy S6 is set to LTE/WCDMA/GSM (auto connect), go to Settings > Mobile networks > Network mode - select network mode 'WCDMA Only'. Do not reboot your phone, otherwise the phone will revert to the default network mode setting. Signal strength should improve by a bar or two. Keep us posted.
Photo of Paula Loh

Paula Loh

  • 110 Points 100 badge 2x thumb
My phone was set to LTE/WCDMA/GSM and I changed it to 'WCDMA Only', but it did not improve the signal strength.
Photo of rikkster

rikkster, Mobile Master

  • 67,104 Points 50k badge 2x thumb
Another option is to reset network settings. Note: The following are cleared or restored to default values: Cellular and Wi-Fi network settings (including saved networks and passwords) and Bluetooth profiles. Go to: Settings > Backup and reset > tap Reset network settings > tap RESET SETTINGS > tap RESET SETTINGS to confirm.

If that doesn't yield any results, there could be an obstruction between you and the nearest cell tower. A device in your home could be causing interference. Walk around the interior of your home and see if you are able to get stronger signal readings in other rooms.

Failing that, you may want to give Koodo customer service a call (*611) or leave a private message on their Facebook page, asking if there any problems with the tower that services your area.
(Edited)