Pissed off with my galaxy ace gts5830d

  • 1
  • Question
  • Updated 5 years ago
  • Answered
I have a samsung galaxy ace gts5830d and every time i come back home i have nothing but problems with it. I have a computer at home and wifi. and right now i am sitting beside my modem. and i can not get google. I tried to install an anti virous app and my pone started installing it then stopped. Why? My phone shows all the wifi bars and yet it says i am not connected and yet if i go into my settings it shows that i am connected. What the hell this happens all the time. I can't even use this pone to make a call because there is no service. I live in duncan b.c. and use shaw. Also if i go to my email it says i have to set up an account i have a gmail account and used to be able to go to my email and it would show me the same things i had on my gmail but not any more. What the frig is going on I am really ticked only happens to me in this area.
Photo of Leslie Mutch

Leslie Mutch

  • 122 Points 100 badge 2x thumb
  • frustrated

Posted 5 years ago

  • 1
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 203,574 Points 100k badge 2x thumb
Try unplugging your home wifi router for a minute or so then plug it back in and then connect back to your wifi connection.
If that doesn't work turn off your wifi on your phone then turn on airplane mode then turn airplane mode off, then turn wifi back on and it should work.
Photo of Ivan

Ivan, Mobile Master

  • 96,634 Points 50k badge 2x thumb
I assume you are able to get other devices connected fine via the same router?

Do you have app updates set to manually update when connected to WiFi. I find that many Android phones (even higher end ones) tend to start to freeze up if I attempt doing anything during the update. I recommend disabling auto-update and doing it manually app by app. It's not like most of those updates are critical patches or anything.

Also, and you're not going to like this possibility, it may be a software bug on your phone that is preventing you from connecting to your router. I've seen this firsthand on the Samsung Galaxy S (first gen) on Gingerbread. As your phone also runs on Gingerbread and is a Samsung, it's not impossible that you may be experiencing a similar issue. The only workaround in my case was a new router. I was creating all sorts of manual settings for the router for over an hour and was not able to come up with a workaround. Hopefully this isn't the case.
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 203,574 Points 100k badge 2x thumb
The Galaxy Ace actually has a kniwn issue when automatically switching from your data connection to a wifi connection, you basically have to do it manually.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
do you know the procedure?
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 203,574 Points 100k badge 2x thumb
No sir I do not, but rikkster and you do. I had the Galaxy Ace for a few months and never had the issue when I had it.
Photo of rikkster

rikkster, Mobile Master

  • 68,350 Points 50k badge 2x thumb
Settings > Wireless and networks > Mobile networks > Use packet data (checkmark to enable data, remove checkmark to disable data)
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Actually I didn't fully understand what you meant but Rikkster apparently did. Learn something new daily. Even something so simple.
Photo of rikkster

rikkster, Mobile Master

  • 68,350 Points 50k badge 2x thumb
To add to Paul and Ivan's recommendations, I would suggest a factory reset which will wipe ALL data (apps, pics, videos, music) from the device's internal storage and re-installs the phones' firmware. It won't touch data stored on your SIM or microSD storage card. Backup what you want to keep onto your computer and then continue with the reset.

To perform a factory reset, tap the phone icon and dial *2767*3855# or go to Settings > Privacy > Factory Data Reset.

The Ace should connect to Wi-Fi without issue after both a factory reset and router reset. You can make it a preferred device using MAC filtering. I wrote a short guide to a MAC filter workaround for the S2x, the method will work for the Ace only that the Ace's menus are a little different than the S2x, everything else (router config) is the same. See link.

To find your Aces Wi-Fi MAC address, go to Settings > Wireless and Networks > WiFi settings. Press the Menu-softkey to the left of the centre Home button and select Advanced. The Wi-Fi MAC address will be a group of six alphanumeric characters separated by colons.

http://community.koodomobile.com/kood...

If all else fails and depending on how long you've had your Ace, it may be time for an upgrade, just a suggestion. The Ace can be a glitchy device and you may want to look for something a little more reliable.
Photo of Mayumi

Mayumi, Mobile Master

  • 115,066 Points 100k badge 2x thumb
When did you buy your phone? (I bought my Ace in June and works great).
If it recent, you might able to use your warranty if all of suggestions above didn't work

This conversation is no longer open for comments or replies.