Phone won't find Koodo network as a carrier.

  • 1
  • Question
  • Updated 3 years ago
  • Answered
I was in the US for 3 days and I bought the 3 day unlimited text plan and it worked great. Now that I'm back in Canada, my phone won't find Koodo as a carrier. The only options that come up are AT&T and 302720. It's like my phone doesn't recognize I'm in Canada.
Photo of Nicole Gingras

Nicole Gingras

  • 154 Points 100 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Ivan

Ivan, Mobile Master

  • 96,382 Points 50k badge 2x thumb
Go into your settings > general > reset. Reset your network settings, your phone will reboot. All WiFi passwords will be lost, but the rest of your data will be fine.
Photo of Nicole Gingras

Nicole Gingras

  • 154 Points 100 badge 2x thumb
Thanks, but this didn't work. The same 2 options come up as carriers.
Photo of Nicole Gingras

Nicole Gingras

  • 154 Points 100 badge 2x thumb
do you have any other ideas?
Photo of Dennis

Dennis, Mobile Master

  • 187,616 Points 100k badge 2x thumb
Try holding the Power and button at the same time until you see the Apple logo, then release. This will do a hard reboot of the device
Photo of Nicole Gingras

Nicole Gingras

  • 154 Points 100 badge 2x thumb
Now when I reset the network settings it finds Koodo, but when I turn off data and 3G it drops Koodo and goes back to AT&T. I don't have a data plan and this wasn't a problem before.
Photo of Nicole Gingras

Nicole Gingras

  • 154 Points 100 badge 2x thumb
I can keep it on Koodo, but I loose service if I turn 3G off.
Photo of Dennis

Dennis, Mobile Master

  • 187,022 Points 100k badge 2x thumb
Koodo uses 3G. That just be on but data can be off

It must be on. This has always been the case
Photo of Ivan

Ivan, Mobile Master

  • 96,382 Points 50k badge 2x thumb
This image is a bit out of date, but the layout should still be similar. Take note that data can be turned off while keeping 3G on. Just make sure you flip the switches the other way: 3G ON, data OFF. Since you don't have data, you can turn your LTE switch to off as well, if applicable.

This conversation is no longer open for comments or replies.