Phone switching between service and no service

  • 1
  • Question
  • Updated 2 years ago
  • Answered
I recently went travelling and unlocked a Samsung galaxy Rugby through Telus. I traveled for 6 months and used the phone in many countries with many different sims, successfully. Once back in Canada I tried to put my koodo sim in, but when I have my koodo sim in my phone, it switches between service and no service. 30 seconds of service then 30 seconds of no service. I called Koodo and we went through a bunch of settings and they tried some things on their end, but after a few days nothing was working. they told me to do a factory reset on my phone so I did. still no luck. The sim works fine since its in my old phone right now. I just can't figure out what the problem is? Any suggestions?
Photo of Spencer Girard

Spencer Girard

  • 140 Points 100 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Daniel Kim

Daniel Kim, Mobile Master

  • 34,736 Points 20k badge 2x thumb
Hi Spencer, do you have WCDMA enabled on the phone in settings?
Photo of Ivan

Ivan, Mobile Master

  • 96,382 Points 50k badge 2x thumb
Have you tried selecting Koodo manually from the carrier list rather than leaving it on automatic?
Photo of Melissa

Melissa, Employee

  • 11,748 Points 10k badge 2x thumb
Hi Spencer!  Did any of the above troubleshooting steps work?  Let us know!
Photo of Spencer Girard

Spencer Girard

  • 140 Points 100 badge 2x thumb
Changed my mobile network to WCDMA only and everything seems to be working fine. Before it was on LTE/GSM/WCDMA (AUTO MODE)
Photo of Spencer Girard

Spencer Girard

  • 140 Points 100 badge 2x thumb
Update, just noticed I can't turn on my data. Everytime I enable it nothing happens.
Photo of rikkster

rikkster, Mobile Master

  • 67,104 Points 50k badge 2x thumb
I'm thinking that the APN settings may still be set to TELUS or another provider you may have used in your travels. You will have to create a new APN or make the necessary correction(s) to the APN to allow Koodo as the default provider and to be able to use data.

To get to the APN settings on your device, go to: 'Settings' > tap 'Wireless & networks' (or 'More') > tap 'Mobile Networks' > tap 'Access Point Names' > tap 'New APN' or the “+” icon > Manually type in the following information:

Name: Koodo
APN: sp.koodo.com
Proxy server: 74.49.0.18
Port: 80
Username:
Password:
Server:
MMSC: http ://aliasredirect.net/proxy/koodo/mmsc
Proxy server: 74.49.0.18
Port: 80
MCC : 302
MNC : 220
APN type : (if this area is editable, you can try using 'default' or an asterisk (*) if you're still having trouble accessing data)

Save the settings and let us know if this works.
Photo of Spencer Girard

Spencer Girard

  • 140 Points 100 badge 2x thumb
Thank you, changing the APN did the trick

This conversation is no longer open for comments or replies.