phone not working while traveling

  • 1
  • Question
  • Updated 1 year ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: no longer applicable

I'm in South Africa, I purchased the International plan but when I dial +1xxx xxx xxxx I get a message saying I am barred from outbound calling. And my texts aren't going through or coming in. Any solutions? I can't even contact Koodo for help
Photo of Sarah Ratchford

Sarah Ratchford

  • 90 Points 75 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 136,982 Points 100k badge 2x thumb
Sign into the koodo self serve website. Add the free "international voice roaming" add on. Then turn airplane mode on and off. When your phone connects it should be working.
Photo of Robert

Robert, Mobile Master

  • 101,020 Points 100k badge 2x thumb
On the other hand, is data roaming enabled on your phone?

To complete Timo's answer, here's how to add the free international roaming packages. There's two of them : 

Connect to sell serve and go to your add-ons

Click to change the add-ons

Search for 1) International Voice Roaming and 2) International Data Roaming

Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,644 Points 100k badge 2x thumb
Try texting yourself to see if text messages are going through.

This conversation is no longer open for comments or replies.