Packet Data/ picture Messaging

  • 1
  • Question
  • Updated 4 years ago
  • Answered
I have the Samsung Galaxy S2X with Koodo on the $25 plan that includes text and picture messaging, In order to picture message, I heard you need enable packet data. I have also had the Koodo network block my phone from using any data, as I do not need it. So if I turn the pocket data on will it charge me?
Photo of Grace Duncan

Grace Duncan

  • 80 Points 75 badge 2x thumb
  • confused & annoyed

Posted 5 years ago

  • 1
Photo of Marcus Fenix

Marcus Fenix

  • 15,752 Points 10k badge 2x thumb
Since you have a data block, it won't matter if you turn the data on. You would need to remove the data block in order for the phone to connect to the data network.
Photo of PD

PD

  • 6,798 Points 5k badge 2x thumb
No it will not charge until you use data.
Photo of needs help

needs help

  • 282 Points 250 badge 2x thumb
i have the same problem with my phone it will not send picture messages ever
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
after you remove the data block follow this tutorial to get picture messaging without using data.

Setting up A Koodo phone for MMS with no additional Data Access
FOR ANDROID DEVICES

Thanks and partial credit to John Burke

Navigate to Settings / Wireless controls / Mobile networks / access point names

You'll be creating two APN's

Add the first apn (usually by hitting the menu key and tapping ADD NEW)

Note: in the example below please omit the spaces between the http: and the address This is done because some websites shorten URL's

Input the following settings (leaving designated fields blank):

APN NAME: Koodo (NoData)
APN: sp.koodo.com
Proxy server:
Port:
Username:
Password:
Server:
MMSC:
Proxy server:
Port:
MCC :
MNC :
APN type :internet

Save this entry (usually by hitting the menu key and selecting SAVE)

Now create a Second APN using the following settings

APN Name: Koodo MMS ALLOW
APN: sp.koodo.com
Proxy server: 74.49.0.18
Port: 80
Username:
Password:
Server:
MMSC: http: //aliasredirect.net/proxy/koodo/mmsc
Proxy server: 74.49.0.18
Port: 80
MCC : 302
MNC : 220
APN type :mms

Now save this entry as you did the first.

On the list of available Access Point Names you'll notice three (or more) entries. Select the Koodo (NoDATA) apn and make it active (you'll notice you can not choose the Koodo MMS ALLOW entry)

Exit the APN menu.

You'll notice the 3G or 4G data indicator has disappeared leaving only the Signal strength indicator. IF YOU HAD PREVIOUSLY TRIED AND FAILED TO SEND PICTURES IT MAY TAKE A FEW MINUTES FOR THE INDICATOR TO DISAPPEAR. When you do send a picture the Data indicator will re-appear and the picture should be sent. Same when you get a picture message.
Photo of Brundain A

Brundain A

  • 60 Points
this didnt work for me and i made sure everything was exactly how it is here.
Photo of Emma Darbyshire

Emma Darbyshire

  • 74 Points
I can't leave the MCC and MNC fields blank. Is that ok? And also the 4G symbol is up all the time. My photo's are sending but I don't want any data being used.
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 139,912 Points 100k badge 2x thumb
MCC and MNC default automatically to 302 (Canada) and 220 (Koodo). The apn for the Koodo (No Data) apn needs to be changed for this trick to work. It can be anything other than what is listed as here. Easiest is to change it to spp.koodo.com, but you can also change it to something like "totally.wrong.apn". The instructions posted here, unfortunately, cannot be edited anymore because there are already comments on them.
Photo of Grace Duncan

Grace Duncan

  • 80 Points 75 badge 2x thumb
AHHH! :D thank you soo much!!! :) it worked!!!!1
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,544 Points 100k badge 2x thumb
you used the trick posted above?
Photo of Brayden Gagne

Brayden Gagne

  • 80 Points 75 badge 2x thumb
Hmm. Doesn't seem to work for me.
Photo of Ahmad

Ahmad

  • 96,102 Points 50k badge 2x thumb
What's the problem exactly? We can't help if you don't tell us what went wrong
Photo of Brayden Gagne

Brayden Gagne

  • 80 Points 75 badge 2x thumb
I've tried all the steps that Chad Burr posted, however, i still cannot send or recieve pictures without turning on data usage and being charged data. Although, right after i restarted my phone the first time after doing those steps, it immedietley sent two pictures that i tried to send about a month ago but would not send any other pictures after that.
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 139,982 Points 100k badge 2x thumb
The steps listed above still require that your data be turned on, they just prevent anything but picture messaging from using it. Data used for picture messaging is not chargeable as long as your plan includes unlimited mms.
Photo of Emma Darbyshire

Emma Darbyshire

  • 74 Points
O I didn't ask the question but that's what I have been wondering. Thanks!
Photo of Brayden Gagne

Brayden Gagne

  • 80 Points 75 badge 2x thumb
Oh ok. I was a little concerned when sending or recieving a picture message would use data. Thank you for the help.
Photo of Skittles

Skittles

  • 90 Points 75 badge 2x thumb
Any chance there's a fix like this for the Iphone? I called asking them to block data 'cause I keep getting charged stupid fees (for things running in the background...my own fault for not shutting everything down before turning the data on to send a pic) - but was told I can either keep doing this and just "be more careful" or have data blocked and then I can't use picture messaging (which to me is unacceptable - they're two separate services according to their rate plans, so why should they be tied together in this matter....)
Photo of Marcus Fenix

Marcus Fenix

  • 15,752 Points 10k badge 2x thumb
Unfortunately no. MMS require an active data connection in order to send & receive media files(such as pictures). While the services are separate, 3g data is required for the transferring of MMS. That's just how the HSPA service is and there's nothing Koodo can do about it.
Photo of John Lee

John Lee

  • 36,724 Points 20k badge 2x thumb
Can't you just unblock your data services and turn off data in the settings of your phone? That should solve your unwanted data charges...
Photo of Kevin Randall

Kevin Randall

  • 60 Points
@Chad Burr
Thanks for this. Huge help!!!
Photo of Intist Sro

Intist Sro

  • 60 Points
How do you prevent it from jumping back to the original APN setting?
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 139,912 Points 100k badge 2x thumb
On LG you can't. On Samsung it doesn't.
You will not be charged for data as long as you do not access the internet. I had the same problem but I just did not use the internet while using picture messaging
Photo of bill smith

bill smith

  • 80 Points 75 badge 2x thumb
I have complained to crtc everyone else should too. Koodo is fishing for data users. How can they advertise an option without having data.
Photo of Zaphod Beeblebrox

Zaphod Beeblebrox

  • 50,798 Points 50k badge 2x thumb
Fishing for data users? Can you elaborate more on this? I am VERY curious.
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 139,912 Points 100k badge 2x thumb
Simple. They advertise unlimited picture messaging. They do no charge for picture messaging, nor do they charge for the data used to send pictures. The fact that data is required is a function of the network and has nothing to do with koodo.
Photo of Zaphod Beeblebrox

Zaphod Beeblebrox

  • 50,798 Points 50k badge 2x thumb
I doubt complaining to the CRTC will have any impact, in my opinion.
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 139,912 Points 100k badge 2x thumb
Indeed. Koodo isn't doing anything illegal, unethical, or even against CRTC regulations.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Seriously? do we need another day of Koodo is logging into my facebook?
Photo of Zaphod Beeblebrox

Zaphod Beeblebrox

  • 50,798 Points 50k badge 2x thumb
Chad, what is the link for reporting users in this community?
Photo of Zaphod Beeblebrox

Zaphod Beeblebrox

  • 50,798 Points 50k badge 2x thumb
Thank you, kind sir *tips hat*
Photo of Emily Fowler

Emily Fowler

  • 110 Points 100 badge 2x thumb
Hi Everyone!

Sorry if this has already been sorted, but I have a Samsung Galaxy Ace GT-S5380D and recently changed my plan to include unlimited sms and mms messaging. I had to unblock data in order to send my picture messages. So now I have several questions.

1) How do I know I'm not inadvertently using data via the gmail icon or google search, even though I haven't clicked them?

2) Does turning off my "packet data" when I'm not sending photos turn off my data connection?

3) I changed my APN to "Koodo (NoData)" because I don't have an option to add any others, and that seemed to work. This created a strange icon at the top of my screen that has an H and two arrows going in opposite directions. What does this mean, and do I have to pay for it whenever it's turned on?

I just want to send picture messages, as my plan says I can do without limit, and I don't want to get slapped with a nasty bill at the end of the month. I've spent all day trying to fix this, and now that the breakthrough successful picture message has been sent I'm terrified it will charge me an arm and a leg.

Thanks for your help!
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 139,912 Points 100k badge 2x thumb
On the original galaxy ace, just change the apn type of the original apn to 'MMS'.
Use packet data is the master on off switch for data on the phone. It blocks (cellular) data use for anything.
The H with the two arrows indicates that data is on. If it appears and the arrows flash when you are actively sending or receiving picture messages that's fine, since data used for pictures is not chargeable. If the arrows flash when doing anything else the phone is using chargeable data.
Photo of Emily Fowler

Emily Fowler

  • 110 Points 100 badge 2x thumb
Thank you so much for your prompt and easy to understand reply! As I said, it's been a long day of trying to understand all this stuff. Have a nice evening :)
Photo of Leslie McCurrach

Leslie McCurrach

  • 80 Points 75 badge 2x thumb
I've tried to change the APN on my Moto G (several times) and when I select "save" from the menu, it doesn't save. I just revert back to the original APNs screen with the original APN name listed.

Any ideas?
Photo of Jorden

Jorden, Mobile Master

  • 33,404 Points 20k badge 2x thumb
Not every phone allows you to edit the APN/works with the above solution unfortunately.

This conversation is no longer open for comments or replies.