overseas "unlocking" phone

  • 1
  • Question
  • Updated 4 years ago
  • Answered
used self-service to be able to call while overseas, got there and it was a fail, unable to connect to network. Needed emergency call home so paid to have phone "unlocked" and used sim card while there. Now back in Canada and phone is still in UK mode even with replacing original card in phone. How do I get reconnected to my Canadian network?
Photo of Leslie Noonan

Leslie Noonan

  • 70 Points

Posted 4 years ago

  • 1
Photo of Daniel Gunn

Daniel Gunn

  • 19,800 Points 10k badge 2x thumb
Hi Leslie,

What phone do you have? This will help us give you answers on being able to get you set up again for being back home.
Photo of Curtules


  • 19,666 Points 10k badge 2x thumb
Hey Leslie,

Sometimes when you're roaming you'll find yourself in a region that only offers 2G service. Since it takes battery life to search for a 3G network your phone will automatically disable 3G if it's not available for an extended period - saving battery life.

Trouble is, your phone doesn't have any way to know if 3G is available if 3G is off. And since Koodo doesn't have 2G service, you won't get service without 3G on.

So, complex explanation - simple solution, you probably just need to turn 3G on.

For Android:
Settings > More/More Settings/More Networks > Mobile Networks > Network Mode/Preferred Network Type > Make sure it's set to include 3G or WCDMA or HSPA, whichever it says

For iPhone:
Settings > Cellular > Enable 3G

For Windows:
Settings > Cellular/Mobile Network > Highest Connection Speed > 3G

For Blackberry 10:
Settings > Network and Connections > Mobile Network > Network Technology > Make sure it includes HSPA+

For Blackberry 7 or lower:
Manage Connections > Mobile Network Options > Network Mode > 3G or 3G & 2G

Hope this helps.
Photo of Chris Petersens

Chris Petersens

  • 47,246 Points 20k badge 2x thumb
In general you need to go to your setting and, depending on the phone you have. look for a tab that says 'cellular networks' or something along that line. The switch to 'automatic'. Likely your phone is on 'manual' and stayed on the last UK provider's setting. Easy to change though.
Photo of Curtules


  • 19,666 Points 10k badge 2x thumb
That too.