Out of country roaming purchased but does not work

  • 1
  • Question
  • Updated 2 years ago
Purchased out of country roaming. Worked fine here last year does not work at all now
Photo of Joanne Harry

Joanne Harry

  • 80 Points 75 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Bernard

Bernard, Official Rep

  • 80,832 Points 50k badge 2x thumb
Where is "here" Joanne? There are updates US carriers make to their network coverage on an ongoing basis. Do you see full bars on your phone for cellular coverage? If yes, that's a good start. Try putting the phone on airplane mode and then back. 
Photo of Joanne Harry

Joanne Harry

  • 80 Points 75 badge 2x thumb
I'm in Punta Cana. Other than a single incoming text immediately proceeding landing I have not been able to use the service at all. No bars are showing up on my phone, and thus no texts will send. I put the same plan on my phone last year;
was located in the same area and had no problems. As this is my communication with home, I really need this problem resolved.
Photo of Bernard

Bernard, Official Rep

  • 80,832 Points 50k badge 2x thumb
If you have no bars at all that seem to indicate no coverage available, for whatever reason, by the local provider. We don't anything in Punta Cana and have no control whatsoever Joanne. One other I suggest you may try is under settings on your phone, look for something called cellular network and you might be able to see if there are other carriers that you could manually switch your phone to.
Photo of Larry Vander Schaaf

Larry Vander Schaaf

  • 100 Points 100 badge 2x thumb
Try going into networks and switching from 3G/LTE/Auto, to anything else.  Then switch it back to Auto (or if it isn't on auto already then switch to that and leave it there.)  Then restart the phone by powering it right down and turning it back on again.  If it still doesn't connect, then go back into networks and try to search for available providers.  If it finds one, click on it.  Don't try to choose Koodo as they don't have any provision where you are but they partner with other local providers.  Choosing anyone should correct it.  Afterward it should be set back to "automatically choose."
Photo of Ivan

Ivan, Mobile Master

  • 96,634 Points 50k badge 2x thumb
If you haven't checked yet, please see if roaming is enabled in your phone's network settings.