OnePlus 3T isn't getting mobile data at all

  • 2
  • Question
  • Updated 1 year ago
  • Answered
  • (Edited)
So I am using a sim from Koodo, and it's set up exactly like the following

https://apn-canada.gishan.net/settings/1457_4_koodo_mobile_apn_settings_for_oneplus_3.php

But I am not getting mobile data. I can make phone calls, send texts, but can't do anything needing data on the phone unless I am on WiFi. I also can't get picture messages even if I am on WiFi.

I have several APNs listed in the settings, should I delete the ones that aren't Koodo? 

I have Clearnet, Koodo SP, Public Mobile, Telus SP and Telus SP Tether. 

I didn't want to remove the non-Koodo ones, as they are all on the sim card from Koodo. So, I assume they should be there??


EDIT - YES, mobile data is turned on. And Airplane mode is off.
Photo of Scott

Scott

  • 152 Points 100 badge 2x thumb
  • concerned

Posted 1 year ago

  • 2
Photo of David

David, Mobile Master

  • 89,014 Points 50k badge 2x thumb
Did you ever have a data block applied to your account?
Photo of Scott

Scott

  • 152 Points 100 badge 2x thumb
Not that I know of.

I figure I'll just nuke those other APNs and see what happens. I'm hesitant to do so, as it's a sim right from Koodo. So, they should have the right settings....
Photo of Scott

Scott

  • 152 Points 100 badge 2x thumb
Thanks for the suggestion., Nuking all the APNs and adding just the Koodo one seemed to fix it. 
Photo of Scott

Scott

  • 152 Points 100 badge 2x thumb
Solved it. No idea why the Koodo SIM had other carriers on it, but I nuked all the APNs off the sim, and just added Koodo back as it was before, rebooted the phone and now I have mobile data.

Thanks for looking and trying to help!
Photo of Ivan

Ivan, Mobile Master

  • 96,280 Points 50k badge 2x thumb
They all are/were a part of the Telus umbrella.
Photo of Jordon Dicks

Jordon Dicks

  • 62 Points
Hey man thanks for the help, my oneplus 3t stopped getting a mobile network too, but after I did the Android 7.0 update there a couple days ago. Had no idea what was going on. I had no apns listed in my settings so I put in the one you had listed in the link, now I got 4g service! Big thanks!