On my LG Nexus 5, I am unable to receive MMS while my data is on. Any solutions?

  • 1
  • Question
  • Updated 3 years ago
  • Answered
As a test, i had my friend send a picture from beside me from another LG Nexus 5 (Phone distance from each other is about 30cm). At that time we both had our data on, but I received no picture from him, but instead a few minute after which i turned off data, i received an error message indicating I failed to received MMS. Solutions?
Photo of Christopher Wu

Christopher Wu

  • 90 Points 75 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Kelsey Overall

Kelsey Overall

  • 204 Points 100 badge 2x thumb
Possoble solutions/remedies:
-maybe you went over your data?
-restart your phone
-clear your cache thru settings/device/storage then tap cache and select OK when you've received the prompt to clear your cache.
-turn WiFi off and just use data (sometimes when I turn my data on to receive an MMS while WiFi is on, I receive an error message... "Unable to retrieve, try again")
-try to turn on airplane mode for a moment then turn it off and see if that's done anything. Sometimes this works when I'm not receiving my notifications from various apps that use data/Internet.
Photo of Kelsey Overall

Kelsey Overall

  • 204 Points 100 badge 2x thumb
Oops...that's possible not possoble lol. Sorry about that.
Photo of Kelsey Overall

Kelsey Overall

  • 204 Points 100 badge 2x thumb
Also.....In the Hangouts app, go the the 3 dots on the top right then Settings>SMS and make sure Auto retrieve is checked
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,560 Points 100k badge 2x thumb
It could be that it just took a little while for the MMS to actually go through and you happened to turn off your data connection just before you were going to receive the MMS, did you try sending another pic from your friend to you or just the one?
If you just tried the one then try doing it again and wait a little longer.
Photo of Dennis

Dennis, Mobile Master

  • 187,616 Points 100k badge 2x thumb
Also double check your APN settings

http://mobilemasters.koodomobile.com/...

This conversation is no longer open for comments or replies.