old phone wont use data

  • 1
  • Question
  • Updated 2 years ago
  • Answered
I just signed up with Koodo today and I am having a problem. I am using my old phone I got from Bell. (an Alcatel Onetouch Idol X) While I am able to make calls, I cant seem to use data on this phone.  To fix this issue, I have tried the following things.

Turned on Data Connection

Turned On Mobile data

Set Network Mode to GSM/WCDDMA auto

Manually Selected Koodo 3G in my Alavailble Networks

Turned Data Roaming on(also tried with it off)

And I am still having problems getting any app to use mobile data. Anyone have any Ideas on why I can't use mobile data, or is my phone just too old?
Photo of stickfaz

stickfaz

  • 200 Points 100 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Mayumi

Mayumi, Mobile Master

  • 115,202 Points 100k badge 2x thumb
Photo of rikkster

rikkster, Mobile Master

  • 68,370 Points 50k badge 2x thumb
Data roaming can be turned off. Everything else looks okay. WCDMA only if you see that setting works too. Koodo does not operate a 2G GSM network, so the phone ends up looking for a network that doesn't exist. Follow Mayumi's suggestion regarding APN settings. Keep us posted.
Photo of stickfaz

stickfaz

  • 200 Points 100 badge 2x thumb
Thank you both. My mobile data is up and running now.
Photo of Roman Jr Rosario

Roman Jr Rosario

  • 70 Points
Try borrowing a koodo phone. Insert your sim and see if you can use it the way you want. This will register your sim into the koodo network. Review the settings in that phone than works and replicate it in your own phone.

This conversation is no longer open for comments or replies.