Nokia 1020 loses signal on Koodo network

  • 2
  • Question
  • Updated 4 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: 1-866-995-6636

Does anyone have a problem with a Nokia 1020 losing the signal connection for around 10 seconds several times a day? The phone is locked to Telus. The tech at the Microsoft store said it was a common problem with the Telus network.
Photo of James A

James A

  • 80 Points 75 badge 2x thumb

Posted 4 years ago

  • 2
Photo of Peter

Peter

  • 4,738 Points 4k badge 2x thumb
That's a cheap shot from the Microsoft store... Shouldn't they have tested this thoroughly before selling the device to the carriers?

Anyhow, I'd recommend calling Koodo's tech team and see if they can help you sort this out.

You can reach Customer Service at 1-866-99-KOODO (1-866-995-6636) or 647-788-4337.
Hours of Operation
Monday − Friday: 10am - 9pm
Saturday: 9am - 7pm
Sunday: 9am - 7pm

Cheers,

Peter
Photo of Ivan

Ivan, Mobile Master

  • 96,382 Points 50k badge 2x thumb
Passing the blame around is sadly an industry standard.
Photo of Ivan

Ivan, Mobile Master

  • 96,382 Points 50k badge 2x thumb
Well, the tech at the Microsoft Store must like passing the buck on to someone else. I've had a similar experience at the Apple Store when they insisted that it was a Koodo problem and not a problem with their phone. My persistence got me an exchange.

Having owned several 1020s, I have not had any such issue. I've had one replaced under warranty because my WiFi/BT would drop, requiring a restart of the phone several times a day.

Do you have LTE enabled? If LTE coverage is spotty at best in my experience and I tend to disable it in my settings. I suggest giving that a try.

This conversation is no longer open for comments or replies.