No 4g connection on Lumia 520?

  • 1
  • Question
  • Updated 5 years ago
  • Answered
Hi

I have a Telus Lumia 520 working on the Koodo network. For some reason I only have 2G and 3G as selectable options for the network settings; no 4G. Why am I only getting 3G as the highest option? How do I get 4G?
Photo of Ryan Peatt

Ryan Peatt

  • 90 Points 75 badge 2x thumb

Posted 5 years ago

  • 1
Photo of Jonathan I

Jonathan I, Mobile Master

  • 114,404 Points 100k badge 2x thumb
The Lumia 520 does not support 4G (aka LTE). HSPA maxes out at 21 mbps whereas HSPA+ hits 42 mbps. Currently only Telus/Koodo and Bell/Virgin networks support HSPA+.
Photo of Ryan Peatt

Ryan Peatt

  • 90 Points 75 badge 2x thumb
Thanks. HSPA should still display an H+ icon, shouldn't it? I only get a 3G icon on the home screen
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 203,412 Points 100k badge 2x thumb
That's all I've ever got on the 520 is a 3g symbol
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Yup me too 3g is all it'll display
Photo of Ivan

Ivan, Mobile Master

  • 96,634 Points 50k badge 2x thumb
I get H+ on my 520. Check your network settings.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Hmm going to try it later, I'm in Ontario in a 4glte area.
Photo of Ivan

Ivan, Mobile Master

  • 96,634 Points 50k badge 2x thumb
Install this app: http://julip.co/2012/12/lumia-810-cha...

It'll create a new menu in your settings. Select Koodo from the list. Even though it's a Koodo phone, this may help.

This conversation is no longer open for comments or replies.