No wetwork, no service, no answer!

  • 1
  • Question
  • Updated 10 months ago
My iPhone 6 has been saying that it's "searching..." for service for the past day and a half now! I happened spontaneously yesterday and it hasn't come back since! I've tried everything I've read before in these forums and the apple website! My wifi works fine but that's it! Any suggestions? Help please!!
Photo of Sophia Bush Anderson

Sophia Bush Anderson

  • 90 Points 75 badge 2x thumb
  • frustrated, worried, upset, nervous

Posted 10 months ago

  • 1
Photo of Robert

Robert, Mobile Master

  • 106,774 Points 100k badge 2x thumb
Hello Sophia,

What have you been trying so far?
Photo of Mayumi

Mayumi, Mobile Master

  • 115,056 Points 100k badge 2x thumb
was it working before?
Yes it has never stopped working like this before. I've tried resetting my network preferences, I tried taking my SIM card out, blowing dust out of the space it fits into, turning my phone off and on again, turning the cellular data off and on again (I don't have data), turning wifi off, turning data on then turning my phone off, waiting a little while before turning it back on again.... I'm not quite sure where to go from here!
Photo of Robert

Robert, Mobile Master

  • 106,774 Points 100k badge 2x thumb
Did you pay all your bills?
Photo of Mathieu

Mathieu, Mobile Master

  • 60,848 Points 50k badge 2x thumb
Are you sure you have an active base plan Sophia?
Photo of David

David, Mobile Master

  • 93,430 Points 50k badge 2x thumb
Could be a bad SIM. Can you stop by a Koodo shop and ask them to assess?
Yes yes and I will try! Thank you for your help!