NO signal on KOODO network after October 1

  • 1
  • Problem
  • Updated 10 months ago
Signal on my KOODO account is dead since October 1. All working fine until that time. Move my SIM card in other cell phone , same problem. Bought new SIM card at KOODO kiosk no difference. Phone displays TELUS SIM not KOODO. however statdy message Network not available. Tried on two different phone devices with
same result. Mind you both worked fine until Sundy October 1. Both working fine with other provide SIM card.
Photo of Metyn

Metyn

  • 130 Points 100 badge 2x thumb

Posted 10 months ago

  • 1
Photo of Dennis

Dennis, Mobile Master

  • 196,856 Points 100k badge 2x thumb
Have you checked your self serve to make sure there is no billing problem?
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Where did you buy these phones?
Photo of Cory

Cory

  • 10,502 Points 10k badge 2x thumb
Is your Account in good standing?
Photo of Metyn

Metyn

  • 130 Points 100 badge 2x thumb
Account is in GOOD standing. Phones came from China. Both worked on BELL and ROGERS
for over 2 years. On KOODO for about 2 months until October 1. Both are still working on ROGERS
network. I traded BELL for KOODO. Maybe a big mistake?
Photo of Jan Hope

Jan Hope

  • 4,356 Points 4k badge 2x thumb
@Metyn

First of all it shouldn't display Telus it should display Koodo. When you have been using it on Koodo for those past 2 months it was displaying Telus, as well? 
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
If the phone is rooted or unlocked from another carrier it may indeed say Telus instead of Koodo. But it doesn't really matter since Telus owns and operates Koodo.

There is a slight possibility that a frequency that used to be available near you is not available now. Especially with foreign phones which sometimes lack all of the frequencies used in North America.

What phones are they?
(Edited)
Photo of BobTheElectrician

BobTheElectrician

  • 67,712 Points 50k badge 2x thumb
If the phones are Android, there should be a setting in More => Mobile Networks => Network operators => Search networks : try doing a search and selecting Koodo or Telus manually rather than using the automatic setting. This may take a few minutes.

A phone normally will latch on to the strongest local signal when on automatic. A local shared tower may now be broadcasting a more powerful "foreign" signal that is not one of the frequencies Koodo uses but that your phone recognizes.
(Edited)
Photo of Metyn

Metyn

  • 130 Points 100 badge 2x thumb
Thank you all for excellent comments and suggestions. It is always good to learn and examine new viewpoints especially if one is over 70. BobTheElectrician  hit it right on.After following his advice forcing manual selection fixed my problem and all is back to normal.Thank again everyone.
Photo of Cory

Cory

  • 10,502 Points 10k badge 2x thumb
Bell and Koodo share networks, so it may be a phone issue.
(Edited)