no service, no verification email, after activating a new account

  • 2
  • Question
  • Updated 5 months ago
  • (Edited)
Hello. Purchased a new prepd sim card and went through the online activation process / set up a new account, about an hour ago. The process apparently completed successfully,  and I can log into the new self serve account ... however, despite having removed and reinserting the sim card several times and rebooting the phone several times, it still is not connecting (says 'no service'), plus I have not received any welcome or verification email. 

*Update: have now received email address verfication and welcome email. Phone still shows no service and there is no carrier listed in phone settings. 

How long should activating the sim card take, so that the phone shows it is on the Koodo network? I know I have to wait a bit for phone number porting from my old proovider, but should connecting to the Koodo network not be fairly prompt after activating?

Any advice or suggestion would be much appreciated.
Photo of Gary

Gary

  • 222 Points 100 badge 2x thumb

Posted 5 months ago

  • 2
Photo of Dinh

Dinh, Mobile Master

  • 32,964 Points 20k badge 2x thumb
If the SIM is new and with a new number, it should be quick.
Which phone are you using? is it compatible with Koodo network? and have you checked if your APN is settings correctly ?  https://www.koodomobile.com/help/setting-data-your-non-koodo-phone
Photo of Gary

Gary

  • 222 Points 100 badge 2x thumb
The phone is an unlocked iphone 4 and yes it is compatible with the Koodo network. It was completely reset and restored last night (prior to the new sim being put in today).

The sim is new, but the phone number is being ported from the old carrier.

I know we have to wait for the number porting, however the last time we did this (different account, different phone, but from the same old carrier) the sim activation occurred pretty much immediately (phone showed as being connected to the Koodo network).

Phone still is saying 'no service' - that doesn't seem right to me.
Photo of Gary

Gary

  • 222 Points 100 badge 2x thumb
This issue is now solved - 3G was not enabled in the phone settings; enabling it allowed the phone to connect to Koodo. D'oh. 

Thanks for reading and trying to help!
Photo of Dinh

Dinh, Mobile Master

  • 32,772 Points 20k badge 2x thumb
Glad that things worked out for you. Cheers