No phone service Huawei P7

  • 1
  • Question
  • Updated 3 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: 1-866-995-6636

I have a Huawei P7 and have set the correct APN settings for koodo but when I connect, it connects to Telus and under network it lists Rogers (roaming). I get data and texting but can not make phone calls. Any ideas for settings I need to change?
Photo of Bill Wiebe

Bill Wiebe

  • 110 Points 100 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
1. Have you tried Restarting the device?

2. When you try to call someone, what happens?
Photo of Bill Wiebe

Bill Wiebe

  • 110 Points 100 badge 2x thumb
Yes I have restarted.
When I call It dials , disconnects, and I get a message "Normal calls are restricted by access control".
Photo of Dennis

Dennis, Mobile Master

  • 196,772 Points 100k badge 2x thumb
Do you have calling restricted on your phone app/settings?
Photo of Bill Wiebe

Bill Wiebe

  • 110 Points 100 badge 2x thumb
When I try to see the settings on the Huawei, I get a sim card/network error. If I put the sim back into my Samsung, it shows no restrictions.
Photo of Dennis

Dennis, Mobile Master

  • 196,772 Points 100k badge 2x thumb
Is this a dual sim phone?

Try using the other sim slot.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
If that doesn't work, you'll want to boot into recovery and perform a factory reset.
Photo of Ivan

Ivan, Mobile Master

  • 96,634 Points 50k badge 2x thumb
You may want to check this out:

http://www.morldtechgossips.com/2014/...
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Nice find! Hope it works.
Photo of Bill Wiebe

Bill Wiebe

  • 110 Points 100 badge 2x thumb
Sim #2 is a micro sim and I don't have one.
Factory reset does not work, even in recovery mode.

I have a setting for preferred networks (PLMN) that has a listing of networks, but there is no listing for koodo. After adding Bell, I could access data from the Bell tower near work but no phone.
Entries for telus are Network ID: 302220 Priority: 0 Network type: 3G.
I can not find a network id for koodo. When I connect with this phone, it lists the network as telus or bell, but connecting to the same tower with my old phone it lists the network as koodo. Under access point names koodo SP is selected.
Photo of Ivan

Ivan, Mobile Master

  • 96,634 Points 50k badge 2x thumb
Koodo has the same network ID as Telus. Try connecting to Telus. I've had the carrier appear as Telus instead of Koodo before in my status bar.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Happening to me now

Photo of Bill Wiebe

Bill Wiebe

  • 110 Points 100 badge 2x thumb
My account still lists my phone as galaxy ace 2. Does the new phone need to be registered on koodo? I tried the swap phone option, but it wants a new sim number. On the first day I did manage to make a few calls with the new phone and it was working fine.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
No there is no addition registration to be done online. The phone on the account is automatically updated after a while.
Photo of Veronica

Veronica

  • 3,528 Points 3k badge 2x thumb
Hello Bill, 

I know you tried a lot of things, but bear with me and try this again. Maybe it will work.

My suggestion is to try to set the APN settings once more (find the procedure here:http://koo.do/1w6CvVI).
Please make sure that after you saved the changes made in the settings, you select Koodo to connect to the Koodo network (not Koodo SP).
In theory, this should help you connect automatically to the Koodo Metwork.  

As to why you cannot call, please go to the call settings, tap on the 3 little dots/squares in the top/bottom corner of the screen (depending on the model), choose settings, voice call/call settings, then options and outgoing calls. You can see there if the calls are restricted from your phone. 

As a last alternative, if nothing works, you can contact our technical support team at 1-866-995-6636 (option 6) from another line and my colleagues will be able to further assist you.

Many thanks!

This conversation is no longer open for comments or replies.