No options for "Select Local Calling Area"

  • 1
  • Question
  • Updated 1 year ago
  • Answered
Hello, I just bought my prepaid sim card this afternoon and I am stuck at step 2 which is choosing a phone number.

I don't have existing mobile numbers here in canada so I opted for the first option which is "select a new number". However, I cannot select a local calling area because the drop down list is blank.

Here is a screenshot.



Your help is very much appreciated. thank you.

Btw, I used chrome and edge to see if it work, but nope :<
Photo of Danielle Infante

Danielle Infante

  • 192 Points 100 badge 2x thumb
  • confused

Posted 2 years ago

  • 1
Photo of Mathieu

Mathieu, Mobile Master

  • 60,848 Points 50k badge 2x thumb
Hey Daniella,

Use internet explorer instead of Edge. For me, the pre-paid sites only work with Internet Explorer and nothing else.
Photo of Danielle Infante

Danielle Infante

  • 192 Points 100 badge 2x thumb
I tried it and it is still blank :(
Photo of rikkster

rikkster, Mobile Master

  • 68,304 Points 50k badge 2x thumb
I'm using Chrome and it's showing the list of local calling areas.

Photo of Danielle Infante

Danielle Infante

  • 192 Points 100 badge 2x thumb
gosh I wonder what's wrong with mine :c

I used both laptop and cellphone for it...
Photo of rikkster

rikkster, Mobile Master

  • 68,304 Points 50k badge 2x thumb
Have you tried clearing the browsers' cache, cookies and history in Chrome?
Photo of BobTheElectrician

BobTheElectrician

  • 67,216 Points 50k badge 2x thumb
Worth a shot: on your laptop, while in Chrome, hit the command and minus keys at the same time (or use View => Zoom Out) to reduce the overall font size.

Your current default font setting may be too big for the allotted chracters to fit within the mini-scroll bar.
Photo of Mary E Ramos

Mary E Ramos

  • 70 Points
Hi, were you able to solve this? What did you do? Having the same issue.