No data on unlocked Lumia 520; talk and SMS OK

  • 1
  • Question
  • Updated 3 years ago
  • Answered
I purchased a monthly 500-minute, 500-gb plan from a kiosk. When I turn on "Data connection," the 4G icon shows at the top right of the screen (Lumia 520s don't work with LTE). However, when I try to view a web page like Google, Internet Explorer displays "Error: Cannot find server or DNS error". I haven't used my self-service account because I assumed that the kiosk tech configured everything as necessary. How do I fix this? Thanks much.
Photo of YOWTurbine

YOWTurbine

  • 110 Points 100 badge 2x thumb

Posted 3 years ago

  • 1
Photo of LairdC

LairdC

  • 5,164 Points 5k badge 2x thumb
It's probably incorrect APN settings. Follow these steps:

https://community.koodomobile.com/koodo/topics/access_point_names_settings
Photo of YOWTurbine

YOWTurbine

  • 110 Points 100 badge 2x thumb
Thanks for your correct answer, Laird. My Lumia 520 runs Windows Phone Cyan, so here's how I updated the Access Point Name (APN). Firstly, tap Settings. If you don't have a Settings tile on your home screen, then tap the arrow from the home screen to your applications list and swipe up until you see Settings. Tap Settings.

Swipe up to cellular + SIM and tap. When the screen appears you'll see that the Active network is Koodo. Tap SIM settings.

If Data connection is on, turn it off.

SIM settings will show Koodo. Tap.

SIM name may be blank. I updated the field to Koodo.

Tap edit internet APN. In the APN field type sp.koodo.com. In the Proxy server (URL) field type 74.49.0.18. In the Proxy port field type 80. Tap the save icon that looks like a diskette.

To update the Multimedia Message Service (MMS) configuration, tap edit MMS APN.

In the APN field, type Koodo. In the MMSC (URL) field, type aliasredirect.net/proxy/koodo/mmsc.

In the MMSC field, type 80.

Tap the save icon that looks like a diskette.

Turn Data connection on.

I haven't tested MMS, but cellular Internet works correctly. Happy Labo(u)r Day holiday.

This conversation is no longer open for comments or replies.