Nexus 4 unable to send MMS

  • 2
  • Question
  • Updated 5 years ago
  • Answered
Just picked up my v3 micro sim from koodo for my new Nexus 4. Data is working fine on both HSPA and LTE however I cannot send mms Even when at home on wifi it wont turn on data to send it. This happened before on my Nexus S a year back but it fixed it self. I tripped checked the APN settings and all is good so not sure why it wont send. I am using SMS Go but I have also tried it on the stock msg app.

Just a note Speedtest.net always has a connection error on data but wifi is fine. Not sure if this is linked in anyway.
Photo of Mike Konowaluk

Mike Konowaluk

  • 312 Points 250 badge 2x thumb

Posted 5 years ago

  • 2
Photo of Ivan

Ivan, Mobile Master

  • 96,382 Points 50k badge 2x thumb
The connection error is due to the proxy settings. Delete the proxy address from your APN and Speedtest should work for your mobile data connection. I don't think that this is linked to your MMS problem.
Photo of Mike Konowaluk

Mike Konowaluk

  • 312 Points 250 badge 2x thumb
Thats correct.
Photo of Ivan

Ivan, Mobile Master

  • 96,382 Points 50k badge 2x thumb
That's strange. I'm not the only person on these boards that got the app to work by deleting the proxy information:

http://community.koodomobile.com/kood...
Photo of Ivan

Ivan, Mobile Master

  • 96,382 Points 50k badge 2x thumb
And regarding MMS, looks like you have the bases covered. The only other thing to do is to perform a factory reset. I've seen that successfully resolve MMS issues. If that fails, it could be a bug in the current N4 ROM.

If you have a friend on another network, try using their SIM and APN settings to send an MMS. If the issue persists, then it's clearly a bug somewhere in the OS in which case you can't really do anything but report it to Google and hope for a patch soon.
Photo of Mike Konowaluk

Mike Konowaluk

  • 312 Points 250 badge 2x thumb
Okay now it works forgot to get rid of port as well. Thanks, but MMS problem is my real issue and anyone has ideas.
Photo of Ivan

Ivan, Mobile Master

  • 96,382 Points 50k badge 2x thumb
I encourage you to check if MMS works on a different carrier (using a SIM from a friend or a relative) to see if the issue you have is carrier-specific.
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,438 Points 100k badge 2x thumb
Are you using the stock messaging app, or are you trying to use a 3rd party messaging app you downloaded like Go SMS?
Photo of Ivan

Ivan, Mobile Master

  • 96,382 Points 50k badge 2x thumb
He's already stated that the problem persists on both stock and Go SMS.
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,438 Points 100k badge 2x thumb
oh sorry, I know there was another person with this issue and it wouldn't work with Go SMS but it would work fine with the stock messaging app.
Have you tried un installing the Go SMS messaging app & trying the stock one again & making sure your Koodo data connection is indeed on? Do all that then while the device is on donation battery & SIM Card pull for a minute or so, them replace them & try the stock messaging app again.
Photo of Mike Konowaluk

Mike Konowaluk

  • 312 Points 250 badge 2x thumb
well it seems to work fine now on the stock app but Go is what I use so this is annoying.
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,438 Points 100k badge 2x thumb
From what I heard the Go SMS app doesn't support Android 4.2 yet, so that is your issue

This conversation is no longer open for comments or replies.