Nexus 4 - Cannot send texts unless already received

  • 1
  • Question
  • Updated 5 years ago
  • Answered
Hi all,

Signed up with Koodo last week, and been having this problem recently.

I cannot send any SMS text messages to people, unless I have received a text from them already. ie/ I can reply to people who text me, but cannot initiate the first text message. Everything else works fine (incoming/outgoing calls, data, etc.)

I am using a Nexus 4 (purhcased directly from Google, not Koodo). I have already tried:
- taking out the SIM card
- resetting APN settings to default, and rejoining sp.koodo
- changing the SMSC settings, but it consistently gives me an "update error" when I try to update it. However, when I press refresh, it gives me ( "+16475800172",145 ). I'm currently on WCDMA Preferred.

Thanks,
DoFu
Photo of Donald Fu

Donald Fu

  • 100 Points 100 badge 2x thumb

Posted 5 years ago

  • 1
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,580 Points 100k badge 2x thumb
Are you texting to the full 11 digit phone # of the person your trying to send the text to, like 1-705-123-4567, it should be like this in your contacts as well.
Photo of Donald Fu

Donald Fu

  • 100 Points 100 badge 2x thumb
just tried it with the 1, still no luck.. the ones that i can reply to don't necessarily have 1 either
Photo of MatB

MatB

  • 32,458 Points 20k badge 2x thumb
SMS messaging centre is ( "+16475800172"). not ( "+16475800172",145 ).
Network mode (LTE/GSM/WCDMA auto)
Photo of Donald Fu

Donald Fu

  • 100 Points 100 badge 2x thumb
weird thing is when i try to change it, it doesn't stick. once i exit and return, its still stuck with 145
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,580 Points 100k badge 2x thumb
Have you tried doing a factory reset?
Photo of Donald Fu

Donald Fu

  • 100 Points 100 badge 2x thumb
Okay, finally got things working.

Turns out it was the "stuck" SMSC. I ended up dl-ing Go SMS Pro and manually changing the SMSC. First few times didn't work, then I tried a number of things:
- cleared cache on all messaging apps
- disabled stock messaging
- soft reboot after every step
- PDU format (07916174850071F2) didn't work
- manual SMSC was +16475800172 (without quotations)

another reboot, and things started working again. Thank you everyone for your help!
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,580 Points 100k badge 2x thumb
Glad to hear you got it working Donald, if you have any other issues feel free to come back and ask us all here and we will do our best to try to help you out. Have a great day Donald.

This conversation is no longer open for comments or replies.