Nexus 6P problem "Your SIM card does not allow a connection to this network"

  • 1
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
I keep having the same message pop when I try to connect to koodo network "Your SIM card does not allow a connection to this network". Really hope someone can help me on this one. 

Just received my Nexus 6P, bought straight from google. I immediately went to the nearest koodo kiosk to get a nano sim. I've let the koodo employees set everything up for me, but none of them could make it work.

When I came back home, I checked the apn setting multiple times. Tried multiple "fixed" I read in threads. Nothing worked. The sim do work in my Moto G. Haven't tried another sim from koodo or from another carrier in the 6P though.

Previous to the 6P, I had a OnePlus One. The sim did work, but the LTE was spotty at best. My first phone on Koodo was the 1 gen Moto G almost 3 years. Could it be that I don't have LTE in my package (the Moto G was only 3g) and it's causing problem activating my new phone? Just spitballing here.
Photo of Alexandre Tremblay

Alexandre Tremblay

  • 90 Points 75 badge 2x thumb

Posted 2 years ago

  • 1
Photo of rikkster

rikkster, Mobile Master

  • 68,370 Points 50k badge 2x thumb
Hi Alexandre,

It could be a defective SIM card. LTE is not part of a rate plan or package. Koodo's nano SIM cards work on both 4G LTE and 4G HSPA+ networks. All you need is a compatible LTE device, which yours' is and the SIM card should work without issue.
 
Depending on where you reside and your proximity to the nearest cell tower, will have an impact on LTE reception. I'm located less than two kilometres from the nearest cell tower and I'm lucky to receive one to two bars of LTE signal reception. Mind you, I'm facing the opposite direction the tower is facing and I'm in a bit of a valley. If I head to the core of the city, reception improves to a consistent three and sometimes four bars.

It looks like a trip back to the Koodo shop. Bring your receipt and ask to try a new SIM card. Keep us posted. 
Photo of Alexandre Tremblay

Alexandre Tremblay

  • 90 Points 75 badge 2x thumb
I've tried my friend's sim card, he's also with Koodo, same problem. Haven't had the chance to try one from another network. If this also doesn't work, I guess I'll contact google technical support.
Photo of rikkster

rikkster, Mobile Master

  • 68,330 Points 50k badge 2x thumb
Check the network type. This can be done one of two ways. The first is through Android by going to: Settings > More > Cellular network settings > Preferred network type. Choose either HSPA+/UMTS or LTE/HSPA+/UMTS. Choosing GSM by itself is redundant because Koodo does not operate a 2G GSM network, nor will this setting work on your phone.

The second way is to dial *#*#4636#*#* from your phones' dial pad. Select Phone information. Scroll down to 'Set preferred network type' and tap on the drop down list. The only settings here that will work are 'WCDMA only' which is equivalent to setting HSPA+/UMTS. Or you can try the 'LTE/WCDMA' setting, provided you're in an area with good LTE reception.

If neither of these methods yield results, then Google support may be able to give a better idea as to what's going on. Keep us posted either way.  
(Edited)
Photo of Lloyd Willett

Lloyd Willett

  • 3,688 Points 3k badge 2x thumb
What is 4G hspa+ does it give you better cellphone single i am in the 418 area
Photo of rikkster

rikkster, Mobile Master

  • 68,330 Points 50k badge 2x thumb
In testing with numerous phones, setting the phone to 'WCDMA only' brought signal strength up to full reception, (five bars, current test device Blackberry Priv). Setting the phone to 'WCDMA only' appears to be the equivalent of setting the device to HSPA+/UMTS.

Your results may vary. A lot depends on where you are in relation to where the nearest cell tower is located. If you're getting spotty LTE coverage, I would recommend switching to WCDMA only. 

HSPA+ is not really 4G, though it is often marketed as such. HSPA+ is an evolution of HSPA that upgrades existing 3G networks to 4G speeds. As the technology continued to evolve, new releases were added as part of the 3GPP standard to include faster downlink and uplink speeds, among other upgrades. 
Photo of Alexandre Tremblay

Alexandre Tremblay

  • 90 Points 75 badge 2x thumb
I've tried going into phone information and setting the preferred network type to "WCDMA only"; I exit the app and it reverts itself to "GSM auto prl".
Photo of rikkster

rikkster, Mobile Master

  • 68,330 Points 50k badge 2x thumb
If using the Android method, (Settings > More > Cellular network settings > Preferred network type), are you able to set 'WCDMA only' or 'HSPA+/UMTS' this way? You don't need to reboot the phone after making changes to the network type. A reboot will revert to the default network type setting.

The Nexus 6P does not support SIM hot-swapping. Huawei recommends that the phone must be powered off when removing or inserting a SIM card. If the phone is powered on and a SIM card is inserted, the phone must be restarted.

Your best option if nothing is working would be to contact Google support. If they come up with a fix, be sure to post back here as it may help others in the community experiencing the same problem. 

This conversation is no longer open for comments or replies.