Nexus 5, S3, Moto G won't connect to wifi

  • 2
  • Question
  • Updated 3 years ago
  • Answered
So my nexus 5 with lollipop started glitching and now it has no internet. Pretty much it says there is internet and etc etc with bars and stuff (full 5 bars) and then it has a ! Right after the wifi symbol at the notification bar. So I try to load some pages and stuff and it says "No internet" when in the notification bar it perfectly points out that there is internet. Does this have anything to do with lollipop,my internet provider, or is it becase koodo is down or something?
Same thing is happening with my moms S3, it says there's internet but there's none (but it has no !) same thing with my dads moto g, it says there's internet but there's none. I'm really pissed off right now because for the past 2 days we've had no internet. For some reason our laptop has no problems connecting to the internet
Photo of Atom Craft

Atom Craft

  • 70 Points

Posted 3 years ago

  • 2
Photo of BobTheElectrician


  • 57,040 Points 50k badge 2x thumb
Re-boot your router.

Shut EVERYTHING down for 10 minutes, then power up modem (Wait Till Ready), router (W T R), laptop and phones EXCEPT for your Nexus.

Routing tables can persist even in a powered-down system.

You don't have lollipop on all your phones, I presume...

Those of us who are of a certain age and can remember the original '60's Lollipop song know what the trademark sound is.. and it's not computer friendly.

The other folks should be up and running. Now turn on your Lollipop and see if that's the troublemaker.
Photo of Jru Gordon

Jru Gordon

  • 9,018 Points 5k badge 2x thumb
Also check to see if anything else that is WiFi capable (routers, laptops, etc) can connect to the WiFi, before and after the router power-cycle.

If you have neighbors that will let you use their WiFi, try connecting to their WiFi. If you can connect to their WiFi but not yours, then there is an issue with your Internet Service and you have to call your ISP. They might just need to reboot your signal (happens to me once in a while)
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,644 Points 100k badge 2x thumb
You can force a service reboot by disconnecting the power to the telco's modem (and pulling the battery in it if applicable). Doing this means the modem has to reestablish a connection.