New hardware is incompatible with the old hardware. The equipment exchange cannot be performed.

  • 1
  • Question
  • Updated 5 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: SS App mentions

I ordered a Nokia 520 online and it came with a new SIM card, but when I try and switch my phone and put in the IMEI number (it doesn't have a MEID) it says "New hardware is incompatible with the old hardware. The equipment exchange cannot be performed." But like... I bought it from their site... HELP
Photo of Gideon longfoot

Gideon longfoot

  • 92 Points 75 badge 2x thumb

Posted 5 years ago

  • 1
Photo of Marcus Fenix

Marcus Fenix

  • 15,752 Points 10k badge 2x thumb
Make sure you're selecting the option to switch your sim card. This will ask you for the serial number of the sim card, not the meid.
Photo of Ivan

Ivan, Mobile Master

  • 96,382 Points 50k badge 2x thumb
You shouldn't have to "register" the phone, just the SIM card.

Go to Self-Serve (website, not mobile app) > Mobile Phone > Swap Mobile Phone (bottom left corner) > Upgrade my current phone > enter your new SIM card number.

Never does it ask me for the IMEI#. IMEI is the GSM counterpart of the MEID. Is your previous device a CDMA phone?

Are you on prepaid?
Photo of Curtules

Curtules

  • 19,666 Points 10k badge 2x thumb
Don't panic, you're just entering the wrong number. What the site is actually looking for is the serial number of the SIM card, the one that starts 891.
Photo of Gideon longfoot

Gideon longfoot

  • 92 Points 75 badge 2x thumb
Hmm well I understand how the whole system works now, but after I enter the sim card and wait 15 mins/more my phone tells me there is no sim card/it's invalid.
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 140,242 Points 100k badge 2x thumb
Are you sure the sim card is correctly inserted?
Photo of Gideon longfoot

Gideon longfoot

  • 92 Points 75 badge 2x thumb
Pretty sure, I've tried it almost every way
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Under settings and mobike network,

Be sure network.selection is on automatic
And highest connection speed is 3g

This conversation is no longer open for comments or replies.