New Activation Failed

  • 2
  • Question
  • Updated 4 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: 1-866-995-6636

I just activated (new) my prepaid plan but the phone is not working. No service, network unknown, phone number unknown. The person at the mall tested my phone and it works on the network. Everything was confirmed OK when I activated on the website. I received activating email as well.
Photo of Michael Kwong

Michael Kwong

  • 140 Points 100 badge 2x thumb

Posted 4 years ago

  • 2
Photo of Mayumi

Mayumi, Mobile Master

  • 115,056 Points 100k badge 2x thumb
How long ago did you activate your phone? You might need wait for 15 minutes or so...
Photo of Michael Kwong

Michael Kwong

  • 140 Points 100 badge 2x thumb
I has been over 30 minutes
Photo of Michael Kwong

Michael Kwong

  • 140 Points 100 badge 2x thumb
When I click on the SIM Toolkit it says "SIM Toolkit is unsupported or not ready"
Photo of Mayumi

Mayumi, Mobile Master

  • 115,056 Points 100k badge 2x thumb
You can try turning the power off and back on.
Photo of Michael Kwong

Michael Kwong

  • 140 Points 100 badge 2x thumb
I have restarted a few times. It seems like it is not reading the SIM but at the mall counter the rep put their SIM in and the phone worked fine.
Photo of Michael Kwong

Michael Kwong

  • 140 Points 100 badge 2x thumb
Is there such thing as a bad SIM card? I don't know what my next step is. Who do I call or where do I go???
Photo of Mayumi

Mayumi, Mobile Master

  • 115,056 Points 100k badge 2x thumb
It could be... You have a "Prepaid" SIM card, right? Do you have another phone to try your SIM card? You might just need give it time.....
You can call Koodo tech support at 1-866-995-6636 option 6
Photo of Michael Kwong

Michael Kwong

  • 140 Points 100 badge 2x thumb
i do not have another phone to try
Photo of Jonathan I

Jonathan I, Mobile Master

  • 114,404 Points 100k badge 2x thumb
I think there's a prepaid server outage going on. A few others are experiencing the same thing.
Photo of Tyler Davison

Tyler Davison

  • 90 Points 75 badge 2x thumb
Not just prepaid, seems to be all new activations
Photo of Michael Kwong

Michael Kwong

  • 140 Points 100 badge 2x thumb
Yes. I talked to tech support and that is what they said also. Just have to wait it out :(

This conversation is no longer open for comments or replies.