New sim, no reception

  • 2
  • Question
  • Updated 2 years ago
  • Answered
I recently set up a new sim card, registered, prepaid, my phone recognizes there is a new Sim, there is no red x next to the reception bars, but there is no reception. I'm in a city so there should be reception. It's been like this for days. I've used different Sims in this phone in the past with no problems.
Photo of newuser

newuser

  • 110 Points 100 badge 2x thumb

Posted 2 years ago

  • 2
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
What phone have you got?
Photo of newuser

newuser

  • 110 Points 100 badge 2x thumb
Sony Xperia. I bought it outside of Canada. I checked the IMEI or whatever it is and it's supposed to be compatible according to the Koodo website.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Can you give me the model number please
Photo of newuser

newuser

  • 110 Points 100 badge 2x thumb
miro ST23i
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
That version of the xperia isn't compatiable With koodo it lacks the 850/1900mhz bands used by Koodos towers
(Edited)
Photo of Chadwick

Chadwick, Mobile Master

  • 33,092 Points 20k badge 2x thumb
Try airplane mode toggling. Sometimes it can help reset the network.
Photo of newuser

newuser

  • 110 Points 100 badge 2x thumb
Thanks, already tried, didn't work

This conversation is no longer open for comments or replies.