New data plan won't work

  • 3
  • Question
  • Updated 2 years ago
  • Answered
I have an iPhone 5s that I got from Koodo with a bare bones 25 dollar a month plan. That plan didn't include data. I decided yesterday to go online to add some data. I chose the 40 dollar a month plan which included 500 mg of data and 500 minutes. However, my data is not working even though it says I have used 0/500 mg of my data under the usage section. It also says that I only have 350 minuted available. Please help. Thanks.
Photo of lindsey hatch

lindsey hatch

  • 100 Points 100 badge 2x thumb
  • annoyed

Posted 2 years ago

  • 3
Photo of Robert

Robert, Mobile Master

  • 109,878 Points 100k badge 2x thumb

Is cellular data active on your phone? Do you have a data block on your account? Did you restart the phone?
Photo of lindsey hatch

lindsey hatch

  • 100 Points 100 badge 2x thumb
I have reset the phone and taken the SIM card out. Data is on. I don't know how to block data on my account.
Photo of Daniel

Daniel, Employee

  • 5,714 Points 5k badge 2x thumb
Hi lindsey! You may have a data block on your account. You can contact us on our Facebook and Twitter accounts so that we can help you with that :)
Photo of lindsey hatch

lindsey hatch

  • 100 Points 100 badge 2x thumb
Alright thanks Daniel!
Photo of Laurel


  • 62 Points
Been having the same problem.  Bought a new iPhone SE yesterday along with the $40/mo plan with 500mb of data and ever since then, I've been able to send and receive texts and calls, but my data has not been working.  I've tried turning off and on the Cellular Data.  I've tried resetting my phone, toggling airplane mode.  Don't know what else to do and from what I hear... calling is next to no help.  I sent Koodo Facebook a message and hope they get back to me otherwise, I may just have to make a trip back to Koodo tomorrow to get this sorted out.  Not very impressed atm.... -_-
Photo of Stephanie Eustace

Stephanie Eustace

  • 62 Points
We are having the same issue. Not impressed at all.
Photo of Nabil

Nabil, Employee

  • 6,968 Points 5k badge 2x thumb
Hi there!

Did you contact us regarding the block data on your account? If you can't remove it from the Self-Serve, we'll do it for you.


This conversation is no longer open for comments or replies.