My nexus 4 won't connect to wifi

  • 1
  • Question
  • Updated 3 years ago
  • Answered
Photo of AshleighBelbin

AshleighBelbin

  • 90 Points 75 badge 2x thumb

Posted 5 years ago

  • 1
Photo of John Burke

John Burke, Mobile Master

  • 71,346 Points 50k badge 2x thumb
What version are you using? Settings--> About phone--> Android Version

Are you using a custom ROM?

Is it a public Wi-Fi network or your own with a password at home?
Photo of AshleighBelbin

AshleighBelbin

  • 90 Points 75 badge 2x thumb
I'm using the 4.2.2
I just got it like three days ago so I think it's just the manufactured version?
And is my own wifi with a password
Photo of Curtules

Curtules

  • 19,666 Points 10k badge 2x thumb
So what happens when you try to connect? Are you finding the wifi network?

Consumer model routers can usually only handle so many devices, so if there are multiple other phones, tablets or computers already connected you could try disconnecting them.

Also try unplugging the router and plugging it back in.

If all else fails you can try connecting to another wifi router to test. (Like at a cafe or something.)
Photo of AshleighBelbin

AshleighBelbin

  • 90 Points 75 badge 2x thumb
Ill try those things for sure :) thank you!
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,438 Points 100k badge 2x thumb
Also go to settings - about phone - check for updates there is a newer version of Android available now 4.3 this is once you get wifi working as the update is just over 300mb in size.

If the other suggestions don't work which unplugging your router for a minute or so usually does the trick. Then make sure your wifi frequency band is set to auto in your phones wifi settings under advanced settings.
Photo of Victor Hotte

Victor Hotte

  • 60 Points
umm mine works fine on home wifi and other wifi private but at mcdonalds walmart etc it wont connect.  :(
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,438 Points 100k badge 2x thumb
Victor when you try to connect to public wifi make sure you open a browser and accept the terms of using that places wifi, if you don't do that it won't connect. The places page will automatically load it's self as soon as you open your browser in most cases.
(Edited)

This conversation is no longer open for comments or replies.