My brand new galaxy s5 keeps losing service but will still say I have full bars, just not say I have 4G. What's wrong?

  • 2
  • Question
  • Updated 4 years ago
  • Answered
I just bought a new Samsung galaxy s5 a week ago and have had no problems except that I keep losing service. I will be sending a text or something when it will say I have no connection, but when I look at the top of my screen it shows I have full bars but no 4G. Also when I do have connection it usually shows I only have 2 or 3 bars at home. What's wrong and how can I fix this?
Photo of Marcus Verhoeven

Marcus Verhoeven

  • 90 Points 75 badge 2x thumb
  • confused and frustrated.

Posted 4 years ago

  • 2
Photo of Dennis

Dennis, Mobile Master

  • 187,022 Points 100k badge 2x thumb
It's within the 15 day return period. Return it and get a new one
Photo of Koodo Customer

Koodo Customer

  • 910 Points 500 badge 2x thumb
Does it say "Emergency Calls Only"?
Photo of Marcus Verhoeven

Marcus Verhoeven

  • 90 Points 75 badge 2x thumb
yes it does
Photo of Jessica Meadows

Jessica Meadows

  • 82 Points 75 badge 2x thumb
My phone is about a year old, maybe a little less; I did a factory reset about a week ago and I have been experiencing the same thing ever since. When it loses service the only way I can regain it is to restart my phone (galaxy s4)
Photo of Ivan

Ivan, Mobile Master

  • 96,382 Points 50k badge 2x thumb
If it's been less than a year, I'd advise you to set up a warranty repair ASAP.

This conversation is no longer open for comments or replies.