My phone keeps switching to data even though WiFi is available. Help!

  • 1
  • Question
  • Updated 12 months ago
  • Answered
I have an Alcatel Idol and for the last few months I have had problems with it switching to data, randomly, even though I am in my home and WiFi is available (as evidenced by the WiFi on my laptop and my partners phone, which is a Samsung, also with Koodo). Additionally, I am within a few feet of my wireless router so distance or interference are not the cause. This has become a huge problem and i am getting quite frustrated. Why is this happening, and what can I do to stop it short of having to constantly switch off my data when I am in my home?
Photo of tigglywiggly

tigglywiggly

  • 100 Points 100 badge 2x thumb
  • frustrated

Posted 12 months ago

  • 1
Photo of rikkster

rikkster, Mobile Master

  • 67,084 Points 50k badge 2x thumb
Allowing your phone to become a preferred device on your wireless router via MAC address association is one way to ensure the phone will always connect to the wireless router. Connecting your phone via WPS may be another option. The Alcatel Idol's antenna system may not be as robust as the laptop or Samsung device.  

Try resetting network settings. On your phone, go to: Settings > Backup and reset > Reset network settings and follow the prompts. 

Download the app Wi-Fi Analyzer. The app contains a signal strength meter, useful for determining how well your phone receives Wi-Fi signals. Once installed, Tap the 'eye' and select Signal Meter. If you see noticeable fluctuations in signal, (needle moving to the far left into the yellow and gray areas), this could indicate a possible hardware problem.

https://play.google.com/store/apps/details?id=com.farproc.wifi.analyzer&hl=en
Photo of tigglywiggly

tigglywiggly

  • 100 Points 100 badge 2x thumb
I have reset the network and downloaded the app you suggested and everything seems fine. Is there any way for the app to notify me if the strength drops? The problem is that the phone shows it is connected to the WiFi so I start watching videos and halfway through I get a message that I have used half of my data without any warning that the phone had switched to data.
Photo of rikkster

rikkster, Mobile Master

  • 67,084 Points 50k badge 2x thumb
No, the app will not notify you when signal strength drops. The best solution is to disable mobile data. Given that you have a strong Wi-Fi signal at home, I see no reason to leave mobile data enabled. Should the Wi-Fi signal drop while watching a movie, I would suggest making the Alcatel Idol a preferred device on your router or using the WPS Push button feature on your phone if your wireless router supports WPS.
Photo of Robert

Robert, Mobile Master

  • 103,644 Points 100k badge 2x thumb
Also, does the phone have the smart network switch enabled? Try going into advanced settings of the WiFi and you'll see that.
Photo of tigglywiggly

tigglywiggly

  • 100 Points 100 badge 2x thumb
There is no explanation smart network switch option, but there is a WiFi Auto Join option, and it is set to off (and I am assuming has been as I was unaware of the option).
Photo of Erwin

Erwin

  • 23,546 Points 20k badge 2x thumb

Are you by any chance trying to connect to a public wifi? because with public wifi you'll have to agree on the terms before they allow access and it will look like your connected but you actually aren't until you agree on the terms.

Photo of tigglywiggly

tigglywiggly

  • 100 Points 100 badge 2x thumb
No, I rarely use my data when I am not home, this is happening when I am in my one bedroom apartment, in my living room, and my wireless modem is less than 5 feet from me, on my couch.