My Phone Has No Service, Help?

  • 1
  • Question
  • Updated 5 months ago
My Moto G4 has had no service on it all day. I've only been at work and home and have never had this problem before.

 I have turned the phone off and turned it back on after a couple of minutes.

 I have turned the phone off and removed the SIM card and then put it back in and turned the phone back on after a couple of minutes. 

My cellular network settings are currently selected as LTE (recommended). I tried the other network types and those also did not work. 

Are there any other suggestions on how to get service back?
Photo of Karl Karji

Karl Karji

  • 100 Points 100 badge 2x thumb
  • annoyed

Posted 5 months ago

  • 1
Photo of Robert

Robert, Mobile Master

  • 109,454 Points 100k badge 2x thumb
Is your bill paid? 
Photo of Karl Karji

Karl Karji

  • 100 Points 100 badge 2x thumb
Yes, my plan is on pre-authorized payments
Photo of Dinh

Dinh, Mobile Master

  • 46,106 Points 20k badge 2x thumb
hi Karl,
Have you tried to reset network settings? The network selection mode should be set to LTE/GSM/UMTS.

Also make sure your account is active in selfserve.
Photo of Karl Karji

Karl Karji

  • 100 Points 100 badge 2x thumb
My account is still active. How would I reset the network settings?

This is what I tried so far concerneing network settings: Settings > Cellular networks> Preferred Network Type > options: LTE (recommended), 3G, 2G.
I tried all three of those options and none worked.
Photo of rikkster

rikkster, Mobile Master

  • 68,950 Points 50k badge 2x thumb
To reset network settings, go to: Settings > Backup and reset. Tap Network settings reset. Tap Reset settings, (if prompted, enter the PIN, password or pattern). To confirm, tap Reset Settings.
Photo of Dinh

Dinh, Mobile Master

  • 46,106 Points 20k badge 2x thumb
Yes, pls follow rikkster instruction.
I would also check your selfserve account. If it suddenly stopped working for no reason, it could be some issues with payment (sometimes autopayment didn't work)
Photo of Karl Karji

Karl Karji

  • 100 Points 100 badge 2x thumb
The reset didn't appear to work, I've checked my selfserve and I do not see any outstanding payments. I think I'll just have to take it to my local Koodoo shop tomorrow. Thanks for the assistance. 
Photo of rikkster

rikkster, Mobile Master

  • 68,950 Points 50k badge 2x thumb
How old is the SIM card? It's possible that the SIM card may be at fault or could be showing signs of age if it's an older SIM card. If you're headed to a Koodo kiosk tomorrow, have the rep check the SIM.

Navigate to Settings > Backup and reset and see if 'Reset settings' is listed as an option. If this feature is present, it will reset your phones' settings to factory default values without erasing any user content. If the problem persists, then I'm leaning more toward an issue with the SIM card.