My international add on for texts doesn't seem to be working in the USA.

  • 1
  • Question
  • Updated 2 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: No longer valid due to Easy Roam

I purchased this add on on October 22. " Added* US Unld min/sms $45 30day Price per Month:$45.00 Service effective on October 22, 2016 ." for my iPhone 5S. Now that we are in the States, I cannot send texts unless I have Wifi. My texts want to send as an Imessage and when I change it to text message it still doesn't go. I get a red ! and not delivered message. My Roaming is turned off and my LTE is enabled. What is wrong, please?
Photo of Lori Lindholm

Lori Lindholm

  • 102 Points 100 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Robert

Robert, Mobile Master

  • 103,784 Points 100k badge 2x thumb
Hello Lori.

If you're making a call, does it work?? Make sure you don't use data because your add-on doesn't include any data!
Photo of Lori Lindholm

Lori Lindholm

  • 102 Points 100 badge 2x thumb
Yes. It works to make a phone call...
Photo of Robert

Robert, Mobile Master

  • 103,784 Points 100k badge 2x thumb
Ok, so the problem is not with the service. Does it happen only to 1 specific person? Or to everyone that has an iPhone? Or all contacts whether they have an iPhone or not?
(Edited)
Photo of Lori Lindholm

Lori Lindholm

  • 102 Points 100 badge 2x thumb
I am home now, so disabled my wifi to try to send messages. It worked now...:/    But this afternoon in the car, it didn't.
Photo of Robert

Robert, Mobile Master

  • 103,784 Points 100k badge 2x thumb
Maybe it was simply a bug go of the moment. Happy you got it sorted out!

Enjoy your trip
Photo of David

David, Mobile Master

  • 89,180 Points 50k badge 2x thumb
Roaming needs to be turned on to access data when travelling outside Canada.
Photo of Robert

Robert, Mobile Master

  • 103,784 Points 100k badge 2x thumb
She doesn't have data so it's better to leave it off since she doesn't need any data to text!
Photo of Lori Lindholm

Lori Lindholm

  • 102 Points 100 badge 2x thumb
On another board I found a suggestion to turn off iMessages when away from Wifi. I did that and now my texts send perfectly. Thank you for your suggestions.
Photo of David

David, Mobile Master

  • 89,180 Points 50k badge 2x thumb
Yes, but be careful that you may not receive Messages from your iPhone friends until you turn Messages on again, as the system may hold messages until you reappear on the system.
Photo of Mathieu

Mathieu, Mobile Master

  • 60,848 Points 50k badge 2x thumb
Turning off iMessages can also take 48 hours to fully turn off as well. I remember when I was making the switch back to Android it took a over a day before I started receiving texts from iPhone users again.

This conversation is no longer open for comments or replies.