My iMessage won't work for my iPhone

  • 1
  • Question
  • Updated 2 years ago
  • Answered
Photo of Ron Chand

Ron Chand

  • 130 Points 100 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Goran

Goran, Mobile Master

  • 96,868 Points 50k badge 2x thumb
So you have data/wi-fi on and you cannot send/receive any imessages? Turn imessage off and on and restart your phone. You can see if sending as SMS will work by making sure it's enabled in settings and then messages. If it's still not working try resetting network settings. You'll lose all saved wi-fi info and Bluetooth connections. After that let us know if it's still not working.
Photo of Mathieu

Mathieu, Mobile Master

  • 60,848 Points 50k badge 2x thumb
Hi Ron,

Is your data enabled? iMessage does require a data connection to work when not connected on Wi-Fi.
Photo of Ron Chand

Ron Chand

  • 130 Points 100 badge 2x thumb
My wifi was greyed out Almost 4 years ago but didn't affected iMessage but from yesterday for some reason it stopped working. I have tried everything from DFU mode to restart and ON/OFF the iMessage. disabling and enabling Celular data
I tried almost everything on the list but unfortunately nothing is work. Text messages are working fine and all in green.
Photo of Ron Chand

Ron Chand

  • 130 Points 100 badge 2x thumb
My safari and email works fine and other apps uses data.
I guess my iPhone 4s has served its purpose lol
Photo of Dennis

Dennis, Mobile Master

  • 195,770 Points 100k badge 2x thumb
A picture is worth a thousand words.

Looks like Apple's server is backed up and your imessage is waiting for activation.  How long has it been stuck like this?

***FYI this would be an Apple server issue and not an issue with your phone or service
(Edited)
Photo of Ron Chand

Ron Chand

  • 130 Points 100 badge 2x thumb
It was like that from yesterday ,bud .
I send and receive messages fine but it's kinda annoying to be missing out on a feature like that
Photo of Dennis

Dennis, Mobile Master

  • 195,770 Points 100k badge 2x thumb
I would be patient and give it a few days.  Or you can call Apple
https://getsupport.apple.com/?caller=psp&PRKEYS=PL133
Photo of Ron Chand

Ron Chand

  • 130 Points 100 badge 2x thumb
Hi Matt , yes my data is enabled
Photo of Melissa

Melissa, Employee

  • 11,748 Points 10k badge 2x thumb
Hey Ron, is the issue resolved? As per Apple's website https://support.apple.com/en-ca/HT201422 you should make sure that you're running the latest iOS version.  Also some users on several chat forums reported that switching airplane mode on/off did the trick. Keep us posted!