Moto G Wifi

  • 1
  • Question
  • Updated 4 months ago
  • Answered
Moto G phone won't connect to the internet, it either says "Avoided poor Internet connection" or it gets stuck on "Authenticating..." and "Obtaining IP address"
Any solutions on how to fix the problem? the wifi usually works.
Photo of Tsh

Tsh

  • 120 Points 100 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,544 Points 100k badge 2x thumb
Is this all wifi or just home wifi?

Try restarting your phone and then your router by unplugging the electric cord for a few seconds.
Photo of Tsh

Tsh

  • 120 Points 100 badge 2x thumb
It usually happens to public wifi (for example wifi at Tim Hortons/The mall) but not at home until today.
Photo of Sheila

Sheila

  • 1,780 Points 1k badge 2x thumb
Try this - go to your settings and turn off wifi. Wait a minute and go back to settings and turn it on again
Photo of Tsh

Tsh

  • 120 Points 100 badge 2x thumb
That isn't working
Photo of Ivan

Ivan, Mobile Master

  • 94,970 Points 50k badge 2x thumb
Your home WiFi may not be running on the best channel. However, not knowing what modem and/or router you have, I wouldn't be able to tell you how to address this.
Photo of Tsh

Tsh

  • 120 Points 100 badge 2x thumb
It's not teh modem because I'm curently on my laptop and the internet is fine. Also my sister has a Moto G too, and the wifi on her phone is working as well
Photo of Daniel Kim

Daniel Kim, Mobile Master

  • 34,736 Points 20k badge 2x thumb
Try going under WiFi on your phone then tap your home WiFi and press forget. Then try scanning for wifI and relogging into your home WiFi.
Photo of Tsh

Tsh

  • 120 Points 100 badge 2x thumb
I already tried that, that hasn't worked.
Photo of rikkster

rikkster, Mobile Master

  • 65,650 Points 50k badge 2x thumb
Make sure the password that you use to access the router is spelled correctly on your Moto G. One digit or letter missing will often result in an "Authenticating..." and "Obtaining IP address" error.

You also have the Moto G set to avoid poor Wi-Fi connections. To disable, go to Settings > Wi-Fi > Advanced and consider changing two settings. Make sure 'Keep Wi-Fi ON during sleep' is set to Always. Make sure 'Avoid Poor Connections' is not ticked or enabled.
Photo of Tsh

Tsh

  • 120 Points 100 badge 2x thumb
I'm not sure what happened but I went out today and came back and now my wifi is working again. So problem solved.
Photo of Bernie Morissette

Bernie Morissette

  • 80 Points 75 badge 2x thumb
I'm having a similar issue. My laptop runs great on the Telus T1200H modem. My phone (Motorola G4 Plus) doesn't. I have logged into the modem on line and the phone is on the list but back on my phone it say Wifi is disconnected. I have searched online, and have reset the phone, Yet no matter, under settings on my phone it says Wifi disconnected. As a result I am burning through far too much data.
(Edited)
Photo of David

David, Mobile Master

  • 81,580 Points 50k badge 2x thumb
Ultimately, you may need to reset your phone to factory settings, but in the meantime, try resetting network settings.
Photo of Bernie Morissette

Bernie Morissette

  • 80 Points 75 badge 2x thumb
resetting phone didn't help
Photo of David

David, Mobile Master

  • 81,580 Points 50k badge 2x thumb
Then it sounds like you ned to chat with the manufacturer, possibly a warranty claim.
Photo of Bernie Morissette

Bernie Morissette

  • 80 Points 75 badge 2x thumb
Yes after chatting with the internet provider and my cel phone provider we covered everything in the troubleshooting process and all signs lead to phone issues. I had unlimited data in the city where I used to live so I was unaware of the wifi issue. I can access wifi through a hot spot such as a web page but not through the network control panel it seems.