Moto G - Mobile data wont turn on

  • 5
  • Question
  • Updated 9 months ago
  • Answered
I use WIFI on my phone whenever I can. However, there are times I have no connection and I do turn the data on. For about a week now the data will NOT come on. I turn the Mobile Date to "ON" but the H+ symbol that tells me I am connected does not appear. When I try to go on a website (like Facebook) it tells me I have no internet connection.

Is it possible that I might have accidentally deactivated something elsewhere? What settings can I check to see if everything is turned on and accurate for my data to turn on.
Photo of worldsbestauntie

worldsbestauntie

  • 230 Points 100 badge 2x thumb

Posted 3 years ago

  • 5
Photo of Dennis

Dennis, Mobile Master

  • 195,954 Points 100k badge 2x thumb
Check you self serve and view your add-ons. Do you have Data block on your account?

If not, try taking out your sim and turning off your phone for a few mins. Then try again
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 203,110 Points 100k badge 2x thumb
Also make sure your APN settings are correct to access data on Koodo's network.

Name KOODO
APN sp.koodo.com
Proxy leave blank
Port leave blank
Username leave blank
Password leave blank
Server leave blank
MMSC http ://aliasredirect.net/proxy/koodo/mmsc
MMS Proxy 74.49.0.18
MMS Port 80
MCC 302
MNC 220
Authentication type None
APN type leave blank
APN Protocol IPv4
APN roaming protocol IPv4
Enable/Disable APN APN enabled
Bearer Unspecified
Photo of Jason Bohn

Jason Bohn

  • 110 Points 100 badge 2x thumb
Had wondered what was up while out trying to use an app
Turned phone off then on and it worked again

Did not have this problem before the latest
Motorola Update Service Update earlier this week
Hopefully when we get the new Lollipop it will be
working properly again
Photo of jupeter

jupeter

  • 60 Points
I also had this problem on my newly acquired Moto G which has immediately upgraded itself to Lollipop. I found that if wifi was on, then data H+ would not connect but as soon as wifi turned off it would connect. At first I too was rebooting phone like Jason. Try it, see if this helps.
Photo of David Krueger

David Krueger

  • 70 Points
Shouldn't I be able to use H+ WITHOUT turning off wifi? Has anyone found a good solution to this? Or know the cause/source of the problem? Does upgrading to lollipop help?
Photo of Marcy Wellz

Marcy Wellz

  • 70 Points
Thank you. This fixed my issue. Appreciate it.
Photo of Andrew Smith

Andrew Smith

  • 70 Points
So I have same issue with htc sense on koodo network ?
Photo of Dennis

Dennis, Mobile Master

  • 195,746 Points 100k badge 2x thumb
Have you tried all the solutions above?
Photo of Andrew Smith

Andrew Smith

  • 70 Points
Mine is a HTC phone on a Koodo network - I tried filling in Apn data from another help site but to no aveil. The above information for apn doesn't relate , does it? A bit clueless with this jargon.
Photo of Ranjan

Ranjan, Official Rep

  • 30,028 Points 20k badge 2x thumb
Have you checked the info. available on this site, Andrew? That should provide everything you need to update settings for a non-Koodo phone.