Moto G: Bluetooth phone earpiece problems : voice commands jump to okay google not my contacts

  • 1
  • Question
  • Updated 2 years ago
  • Answered
motoG 1st edition: had for 2 years Ihad it set up for bluetooth earpiece to make calls worked all this time but now when I push the blue tooth button to make a call My phone goes to okay google, not even Google NOw; okay google needs wifi or data I don't have a data plan nor wifi when Iam not at home : never had this problem before; Checked bluetooth on someone elses phone and it works perfectly? I need a fix
Photo of Allan Rudolf

Allan Rudolf

  • 130 Points 100 badge 2x thumb
  • Puzzled

Posted 2 years ago

  • 1
Photo of Chadwick

Chadwick, Mobile Master

  • 33,072 Points 20k badge 2x thumb
Try going to Bluetooth. Forget all devices. And re pair it with your phone. Hopefully that helps.
Photo of Allan Rudolf

Allan Rudolf

  • 130 Points 100 badge 2x thumb
Explain Yourself  How can I repair it  I tried everything even different apps  nothing works The only thing I didn't try was factory reset.
Photo of Chadwick

Chadwick, Mobile Master

  • 33,072 Points 20k badge 2x thumb
Try googling it. Tons of videos on how to pair Bluetooth with moto g.

There should be an option to forget. Or unpair that device. Than try re searching and add it back to your moto g.
(Edited)
Photo of Allan Rudolf

Allan Rudolf

  • 130 Points 100 badge 2x thumb
My bluebooth is paired and connected: I can give  voice commands to okay google but when I want to use it to phone a contact instead of going to google now and  just say call " ?" it jumps into a okay google search but doesn't connect me to my phone number like it used to.
(Edited)
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Have you tried saying call after the prompt?
Photo of Allan Rudolf

Allan Rudolf

  • 130 Points 100 badge 2x thumb
yes and evey other reasonal command that i thought might work like dial etc>
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
What Bluetooth device do you have?
Photo of Allan Rudolf

Allan Rudolf

  • 130 Points 100 badge 2x thumb
samsung HM7000
Photo of Allan Rudolf

Allan Rudolf

  • 130 Points 100 badge 2x thumb
I just disconnected the bluetooth device unpaired it turn the phone off restarted reconnected bluetooth to phone and the same old thing.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Goto settings... Applications.... Google and clear the defaults.

Then tap the Bluetooth headset button... See if there is a pop up that says "open with"

Make note of each app and try each app.
(Edited)
Photo of Allan Rudolf

Allan Rudolf

  • 130 Points 100 badge 2x thumb

I tried that but when a  when i tap the bluetooth headset button nothing pops up:

If I try to make a call with WIFI on it goes through  with okay google however if I turn it off nothing happens saying iam not connected because okay google works with wifi not the phone like google now is suppose to or like it did befor i had this problem

Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,580 Points 100k badge 2x thumb
Have you recently updated Google app or the Moto assist app?
Have you tried going into the Google settings within the Google app and turning off Google Now voice recognition?

This conversation is no longer open for comments or replies.