Cannot send and receive picture messages with Samsung Galaxy Ace

  • 3
  • Question
  • Updated 4 years ago
  • Answered
  • (Edited)
So, I'm having trouble sending and receiving picture messages with my Galaxy Ace with a 150mb Data plan.
It was solved last time by increasing my text limit.

But the thing now is, I have to have the data turned on while the person is sending a picture. If it is not on at that moment, I get a text that says "downloading" but I never get it. But by leaving my data on all the time lets other apps eat away at my limit :(

I tried created the two APN's, one that says Koodo(NoData) and Koodo MMS ALLOW, and have selected the no data one,
but still, my data is just turned on all the time and is being used by other apps.
And I can no longer send or receive mms at all!

I'm completely at a frustrated loss. Please help fix this :(
Photo of Ashley Mamii Nana

Ashley Mamii Nana

  • 262 Points 250 badge 2x thumb
  • frustrated

Posted 5 years ago

  • 3
Photo of Ahmad

Ahmad

  • 96,102 Points 50k badge 2x thumb
Setting up A Koodo phone for MMS with no additional Data Access

Navigate to Settings / Wireless controls / Mobile networks / access point names

You'll be creating two APN's

Add the first apn (usually by hitting the menu key and tapping ADD NEW)

Note: in the example below please omit the spaces between the http: and the address This is done because some websites shorten URL's

Input the following settings (leaving designated fields blank):

APN NAME: Koodo (NoData)
APN: sp.koodo.com
Proxy server:
Port:
Username:
Password:
Server:
MMSC:
Proxy server:
Port:
MCC :
MNC :
APN type :internet

Save this entry (usually by hitting the menu key and selecting SAVE)

Now create a Second APN using the following settings

APN Name: Koodo MMS ALLOW
APN: sp.koodo.com
Proxy server: 74.49.0.18
Port: 80
Username:
Password:
Server:
MMSC: http: //aliasredirect.net/proxy/koodo/mmsc
Proxy server: 74.49.0.18
Port: 80
MCC : 302
MNC : 220
APN type :mms

Now save this entry as you did the first.

On the list of available Access Point Names you'll notice three (or more) entries. Select the Koodo (NoDATA) apn and make it active (you'll notice you can not choose the Koodo MMS ALLOW entry)

Exit the APN menu.

You'll notice the 3G or 4G data indicator has disapeard leaving only the Signal strength indicator. When you do send a picture the Data indicator will re-appear and the picture should be sent. Same when you get a picture message.
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 142,766 Points 100k badge 2x thumb
Mobile data needs to be on. That's your master switch. What we're doing here is fiddling with the individual breakers.
MCC must be 302 (Canada) and MNC must be 220 (koodo). They aren't specified because the phone picks them up from the sim automatically.
Photo of Eric Hamilton

Eric Hamilton

  • 80 Points 75 badge 2x thumb
so i enabled data after setting up the apns listed above and then turned off my wifi and my phone began accessing the 4g network. it now shows data usage for facebook, messenger, android, etc. am i going to be charged for that?
Photo of Eric Hamilton

Eric Hamilton

  • 80 Points 75 badge 2x thumb
at first it was on only briefly to receive a picture message but then when i clicked firefox it instantly started accessing 4g
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 142,766 Points 100k badge 2x thumb
The instructions above, as written don't work. You need to change the apn for the no data one to something other than sp.koodo.com. I use spp.koodo.com, but it doesn't matter as long as it's wrong. The initial post cannot be edited because people have already commented on it.
Photo of Annemarie Baker

Annemarie Baker

  • 60 Points
Thanks very much to the above Ahmad and Timo. This works if you follow the advice from both. No problems whatsoever.
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 142,766 Points 100k badge 2x thumb
On the galaxy ace you can just set the default apn to mms. No other complicated settings required.
Photo of Ashley Mamii Nana

Ashley Mamii Nana

  • 262 Points 250 badge 2x thumb
^ Ahh perfect! Thank you very much sir!
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
glad we all could help you. happy picturing
Photo of Dan Smith

Dan Smith

  • 234 Points 100 badge 2x thumb
Hi prodigy can you tell me how i set the default apn to mms on galaxy ace II x please :)
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
The ace 2x doesn't allow you to edit the default apn so you'll need to follow the example above.
Photo of Gipsas Ceplinskas

Gipsas Ceplinskas

  • 60 Points
i cant get pictures when someone send me picture it say dowload i press then it say dowloading that it then it is staying like that all the time please help me
Photo of Aaron Heinrichs

Aaron Heinrichs

  • 768 Points 500 badge 2x thumb
Phone Koodo and ask if you accidentally blocked the data, or they did by some God awful chance.....hehehehe. I tried sending a pic text and it got rejected and i remembered i had accidentally blocked it.

This conversation is no longer open for comments or replies.