Mobile Data on Samsung Galaxy S3 doesn't work

  • 1
  • Question
  • Updated 2 years ago
  • Answered
I have entered all the correct APN info, but it doesn't work even though I turn it on. My browser just says i'm offline, and koodo says I haven't used any at all.
Photo of liam d

liam d

  • 100 Points 100 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Nabil

Nabil, Employee

  • 6,866 Points 5k badge 2x thumb
Hey Liam,

Could you please show us the APN you entered?

Can you try this?

Name: Koodo
Proxy: leave blank
Port: leave blank
Username: leave blank
Password: leave blank
Server: leave blank
MMS Proxy:
MMS Port: 80
MCC: 302
MNC: 220
Authentication type: PAP
APN type: leave blank

Once you've done it, select Save/Done. Select Koodo to connect to the network. We also recommend to turn off your phone for a minute and then try to connect to internet with your browser.

Hope this helps.

Photo of liam d

liam d

  • 100 Points 100 badge 2x thumb
I entered that APN, but still nothing worked
Photo of Tayeb A

Tayeb A, Employee

  • 18,208 Points 10k badge 2x thumb
Thanks for your reply Liam! Could you double-check if there's no space on the fields you left blank and also make sure there's none after the values you've entered.

Keep us posted! 
Photo of Tiz


  • 4,604 Points 4k badge 2x thumb
It might also help to remove the battery for a couple of minutes

This conversation is no longer open for comments or replies.