MMS not working: Blackberry Curve 9320

  • 3
  • Question
  • Updated 5 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

My blackberry curve 9320 is neither sending nor receiving picture (MMS) messages.

The research I've done said to click the text messages icon, press the menu key, and then select options. Apparently this section should have an MMS section, but that does not appear on my phone. All that shows up are "General Text Messaging Options" and "SMS."

I have unlimited SMS and MMS on my phone plan.

Does anyone know how I can fix this? Please help if you can!
Photo of new to blackberry

new to blackberry

  • 194 Points 100 badge 2x thumb
  • frustrated

Posted 5 years ago

  • 3
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,584 Points 100k badge 2x thumb
Do you have data enabled, it needs to be on to be abke to send mms on Koodo's network.
Photo of new to blackberry

new to blackberry

  • 194 Points 100 badge 2x thumb
I believe I do have data enabled. I can receive email messages and have browser service.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
I do belive that it had to be carrier enabled for the Curve and I don't think it is on Koodo phones which might be why you don't see it.

Is there an option to share pictures via text?
Photo of new to blackberry

new to blackberry

  • 194 Points 100 badge 2x thumb
No, just through email, Facebook, or Bluetooth.
Could you please elaborate on what you meant by "carrier enabled?"
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Some carriers allowed mms and others did not. This is an older BlackBerry and I don't think MMS was enabled for koodo. I could be wrong. This is just how I remember it.
Photo of Xavier

Xavier

  • 7,610 Points 5k badge 2x thumb
Sorry Chad, but the blackberry curve 9320 is MMS enabled. It should work!
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Is this a Koodo BlackBerry?
Photo of new to blackberry

new to blackberry

  • 194 Points 100 badge 2x thumb
Unfortunately it doesn't work, though. Any suggestions on how to proceed would be greatly appreciated
Photo of Xavier

Xavier

  • 7,610 Points 5k badge 2x thumb
Options > Device > Advances system settings > and make sure apn is bb.koodo.com

Then, Go to Options.
Select Networks and Connections.
Select Mobile Networks.
Verify that Data services is on.

Pull out the battery and try again.

You must have a blackberry data plan enabled. What plan do you have? Did it ever work before?



*** To make sure it works, send a picture message to your own phone number. To check if picture is uploaded and downloaded back. ***
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Totally forgot about BIS. You must have the BlackBerry version of your plan in order to get anything that requires data to work (which would include mms)
Photo of Xavier

Xavier

  • 7,610 Points 5k badge 2x thumb
Yes :( Hopefully he has a BIS plan.
Photo of new to blackberry

new to blackberry

  • 194 Points 100 badge 2x thumb
Okay, followed all of your suggestions. Data services is on. I have the CAN Talk & Text 300+ Min $40 plan, which includes pay-per-use data. There is no data block on my account, and both reps that I talked to insisted that I should be able to send and receive picture messages
Photo of new to blackberry

new to blackberry

  • 194 Points 100 badge 2x thumb
The rep who sold me the blackberry set up this plan. Is it possible that she made a mistake by not giving me the blackberry version of the plan?
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Go into self serve and add the BlackBerry data saver access add on. It's free. Right now you probably don't have the access to BIS which you need.
Photo of new to blackberry

new to blackberry

  • 194 Points 100 badge 2x thumb
You were right, it was no selected as an add-on. Thanks! Hopefully it will work soon
Photo of Xavier

Xavier

  • 7,610 Points 5k badge 2x thumb
Note: To access pay-per-use Data Saver on the BlackBerry Curve and Bold smartphones, manually add the Data Saver BlackBerry Access add-on.

How bad, go to self-serve and add it yourself. I's free.

________________________
If you see a good answer, give it a star.
Photo of new to blackberry

new to blackberry

  • 194 Points 100 badge 2x thumb
*not
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Make sure to do a full restart / battery pull. You may also need to register the BlackBerry again.

Btw keep in mind that you are enabling data by doing this. If you don't want to be charged for lots of data make sure you turn data off when you're not actively using it.

You can do that under the network connections settings.
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 140,242 Points 100k badge 2x thumb
It's a blackberry curve. With the level of data compression on these phones, a LOT of data is probably stretching it a tad. It will certainly use more than it has been though.
Photo of new to blackberry

new to blackberry

  • 194 Points 100 badge 2x thumb
I was told that the data charges would only apply when I was not connected to a wireless network. Is that still the case?
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 140,242 Points 100k badge 2x thumb
yes.
Photo of new to blackberry

new to blackberry

  • 194 Points 100 badge 2x thumb
So in theory, I could just turn it on and off depending on whether i'm connected to a wireless network?
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Timo is correct again
Photo of new to blackberry

new to blackberry

  • 194 Points 100 badge 2x thumb
Excellent. Thank-you guys

This conversation is no longer open for comments or replies.