MMS send works, MMS receive does not

  • 2
  • Question
  • Updated 3 years ago
  • Answered
Hi.  I have a Samsung S6 running Android 5.0.1 on a Koodo prepaid account.  My friend has an iPhone 4s on Rogers prepaid.  I can successful send him an MMS.  If he tries to send me an MMS I get a notification that the message was not received.  I have Network node set to GSM/HSPA/LTE (auto connect). My APN settings appear to be correct based on what I've read in the other posts.

Any ideas?
Photo of Paul Calamai

Paul Calamai

  • 340 Points 250 badge 2x thumb

Posted 3 years ago

  • 2
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,448 Points 100k badge 2x thumb
Is he trying to send you an iMessage possibly which Android devices obviously can not receive since it's a primary Apple service.
Photo of Paul Calamai

Paul Calamai

  • 340 Points 250 badge 2x thumb
He disabled iMessage before he sent the MMS so that is not the problem.  However, I discovered today that if I change my Network Mode selection to either HSPA (only) or to GSM/HSPA (only) then I do receive the MMS he sends.  So, the question is, why don't I receive the MMS he sends if my Network Mode setting is GSM/HSPA/LTE (auto connect)?
Photo of Ahmad

Ahmad

  • 96,102 Points 50k badge 2x thumb
i thought so... THAT is what was most likely the problem then. Make sure your apn settings are right for mms

http://aide.koodomobile.com/Portals/0...
(Edited)
Photo of Paul Calamai

Paul Calamai

  • 340 Points 250 badge 2x thumb
The only thing that is different in my settings is APN type which is set as default,mms,supl,dun
Is that a problem?
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,448 Points 100k badge 2x thumb
Try it without the dun I don't have that part of the line on my S6, mine just reads default, mms, supl
Photo of Paul Calamai

Paul Calamai

  • 340 Points 250 badge 2x thumb
Funny.  I just created a new setup with APN type left blank and that worked!
So, now the problem is, what should APN type be?  Should it be blank (as in the link you sent) or should it read default,mms,supl  as yours is?
Photo of Paul Calamai

Paul Calamai

  • 340 Points 250 badge 2x thumb
Sorry, I meant in the link that Ahmad sent.

This conversation is no longer open for comments or replies.