MMS not fully working

  • 1
  • Question
  • Updated 3 years ago
  • Answered
Hey guys. I recently switched over from telus to Koodo, and now my Samsung s3 is no longer sending mms messages. It can receive them though. I'm pretty sure I have all the apn settings right, and my mobile data is turned on, so I'm not sure whats up? Why would I be able to receive, but not send mms?
Photo of Reuben  Brouwer

Reuben Brouwer

  • 110 Points 100 badge 2x thumb

Posted 3 years ago

  • 1
Photo of BobTheElectrician

BobTheElectrician

  • 61,556 Points 50k badge 2x thumb
1. Settings=>More networks=>Mobile networks=> make sure Mobile data is checked (you've already done this).

2. In the same window, Network mode => LTE/WCDMA/GSM should be selected. You can toggle between the first 2 values and re-start your phone. Sometimes this will fix connection problems.

3. double check APN settings:

http://aide.koodomobile.com/Portals/0...

4. Settings=>More networks=>Mobile networks=>Network operators (it may take some time to scan all available networks)=>Choose “Select automatically”

Re-start the phone, preferably by removing the battery for a few minutes.
Photo of Dennis

Dennis, Mobile Master

  • 187,022 Points 100k badge 2x thumb
Photo of Reuben  Brouwer

Reuben Brouwer

  • 110 Points 100 badge 2x thumb
Thanks for the help.

I think I've tried it all fellas. Nothing seems to be working.
Photo of Dennis

Dennis, Mobile Master

  • 187,022 Points 100k badge 2x thumb
Maybe it's time for a backup and factory reset?
Photo of BobTheElectrician

BobTheElectrician

  • 61,556 Points 50k badge 2x thumb
APN settings: change APN type from blanks to "default,mms,supl" with no quotes or spaces. This solved a trick with another carrier.

App settings => Messaging => Clear cache & clear data -- worth a try.

You will most likely lose all your messages, but less drastic than factory reset.

Another option: try another messaging app such as Hangouts. If the problem persists, then it's really a connection issue.

This conversation is no longer open for comments or replies.