MMs issue(correct APN setting)

  • 1
  • Question
  • Updated 4 months ago
  • Answered
I changed from Public to Koodo this week-end. Since Saturday I'm not able to send or receive MMS. 
My data is On
I have Data
I have a good reception
I've set the APN with the Koodo information*
Power cycle my phone a few time between each change
I'm on android 7.0(nougat) with a Sony Xperia 5

I do get internet via my data no problem, and do receive/send regular text. 
Only my MMs are not working.

I also tried leaving the proxy/port empty and just filling the MMS part but it didnt change anything.

at the moment I have 4 MMS waiting to be downloaded..I can't see who sent them and can't download them.

*current info for the APN
Name: Koodo Mobile 
MMS proxy:
MMS port:80
MCC: 302
Authentication type
APN type:default,mms
APN protocol: IPv4
APN roaming protocol: IPv4
Bearer: Unspecified 
APN PPP phone number: Not set
Photo of senko diaz verheyden

senko diaz verheyden

  • 90 Points 75 badge 2x thumb
  • frustrated

Posted 1 year ago

  • 1
Photo of Goran

Goran, Mobile Master

  • 100,712 Points 100k badge 2x thumb
They seem a little off, although it could jsut be auto-filled. Did you leave the fields blank andf they filled themselves? These are the settings

 Name Koodo
 Proxy Leave blank
 Port Leave blank
 Username Leave blank
Password Leave blank
Server Leave blank
MMSC proxy
MMS port 80
MCC 302
MNC 220
Authentication type Leave blank
 APN type Leave blank

Did you delete the APN settings and create a new one or just modify an existing one?
I've tried this one too it doesn't work, i did a network reset and even with the blank and your setting it doesn't work out.(yes i did a power cycle just after saving)

I'm currently thinking it might be an issue with my plan not activating correctly(i did tech support for cellphone so i went trough the whole process that customers can do)

as said it's not an issue with my phone, my old setting with public mobile worked just fine.(saturday before my public account expire i tried switching the sim card to see if my phone had issue receiving/sending mms from public and no it didn't have any issue)
Photo of Dennis

Dennis, Mobile Master

  • 201,124 Points 100k badge 2x thumb
Does your regular data work ?
Photo of Goran

Goran, Mobile Master

  • 100,712 Points 100k badge 2x thumb
Well, it does seem to point to something out of your control if that's the case. It could very well be worth contacting a rep to have it looked at. You can always send a private message via Facebook Messenger or DM via Twitter and someone should get back to you within a couple hours.
yes my regular data is working, I'll see if my friend can fix it later and contact the support team if nothing works :/ still 4days without mms...and the rep didn't even mention how to set up the APN when i went in the shop... so yeah i had bad customer service too and now i'm stuck..

Thanks guys :O 
Photo of Dennis

Dennis, Mobile Master

  • 201,124 Points 100k badge 2x thumb
Have tried adding a new APN and set the APN type to MMS only?
Photo of Chad Burr

Chad Burr, Mobile Master

  • 204,088 Points 100k badge 2x thumb
Can you try using different messaging app? Try Chomp or GoSMS Pro
Photo of Nora Joan Allen

Nora Joan Allen

  • 60 Points
I'm having the same issue, MMS won't work! Galaxy 3, did everything mentioned above! Frustrating ..
Photo of Allan

Allan, Mobile Master

  • 65,768 Points 50k badge 2x thumb
Try turning your WiFi off and your data on. Then try sending/revceiving an mms.
Photo of Ryan


  • 80 Points 75 badge 2x thumb
I am having the same issue. I recently switched to Koodo. I am using my phone from Bell (same as above mentioned) Sony Xperia Z5 Premium. All of my settings are correct, went back to Koodo, they checked the settings in my phone, put my sim card in another phone which worked fine. But I cannot send or receive MMS either. Everything else works, Data, calls and texts. Was there ever a solution to this issue?
Photo of Dinh

Dinh, Mobile Master

  • 46,168 Points 20k badge 2x thumb
Hi Ryan,
Have you checked if your APN has been setup as per this:
From your description, the MMSC might not be set correctly. I would double check if it was set to:

Proxy URL
Proxy username     Blank
Proxy password     Blank
Photo of BobTheElectrician


  • 69,822 Points 50k badge 2x thumb
The Proxy URL might be
with Port set on a separate line at 80

After checking APN, try toggling network mode between with and without LTE.
Photo of Dinh

Dinh, Mobile Master

  • 46,168 Points 20k badge 2x thumb
Yeah, Bob is right, it should be 80 is for the port.
Photo of Ryan


  • 80 Points 75 badge 2x thumb
Hi Guys, 

Those are all the settings I have. I have attached screen shots to show you all the settings. Like I mentioned above, I had the guys at Koodo look it over and they tried it in another phone, so I don't understand why this isn't working. Its been very frustrating as I haven't been receiving messages and unable to send messages because of this. I use this phone for work so this issue needs to be resolved asap please. 
Photo of Dinh

Dinh, Mobile Master

  • 46,168 Points 20k badge 2x thumb
So you have checked your SIM with another phone, and MMS didn't work or worked?. If it didn't work then it could be another issue of network settings.

As you mentioned, you just ported. I would try to restart the phone and test. If it doesn't work, you could call Koodo technical support/send message to their facebook to look over the issue.
Photo of Ryan


  • 80 Points 75 badge 2x thumb
When they put my sim card in another phone they were able to send picture messages no problem. Everything worked fine. I will have to have them look into it further. No one can seem to resolve the issue. 
Photo of BobTheElectrician


  • 69,906 Points 50k badge 2x thumb
Re-boot the phone without the SIM inserted. You will get an error message, but that should flush your old set-up and connection.

Re-insert the SIM and re-boot.

When doing a seasonal change from a US supplier and back to Koodo, the APN files on my old Note 2 would magically appear or disappear depending on which SIM was in the phone. It sometimes took a couple of restarts before everything (system time, etc) got back to normal.

You could also try changing APN type to:

APN type: default,mms,supl,duns

That solved a few issues on my Note 2.

Won't cost  you anything to try, and easily reversible.
Photo of Sunspot


  • 160 Points 100 badge 2x thumb
I have had the same problem for the last four months since I changed to Koodo and I tried everything listed in this thread, but nothing worked.
Now I finally found a solution, and it is pretty simple. In APN Type mark default,mms,supl save it and reboot the device.
I hope that will help someone as it helped me!