Magic data off button that still allows picture messaging?

  • 1
  • Question
  • Updated 4 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

Just got a Samsung Galaxy Ace 2 X. I don't want to use data if I can help it but I do want to send and receive picture messages. Is there a magic button to allow this or do I have to individually check each app and turn the data off for each one. (Or in the case of Android OS which doesn't give me that option) Or turn the whole data package off and therefore have to get a text from someone saying "hey I'm going to send you a picture, turn your data on."
Photo of Dan Nicholson

Dan Nicholson

  • 464 Points 250 badge 2x thumb

Posted 5 years ago

  • 1
Photo of Camilo_A

Camilo_A

  • 31,072 Points 20k badge 2x thumb
There is a WIDGET call DATA ENABLER, get it at the PLAY STORE, install it on the phone's homescreen and just by tapping you will be able to ENABLE/DISABLE the data on your phone.

So enable when sending PIC messages and disable the data as soon as the message is sent...

The data used by the phone does not come from the PICTURE MESSAGES but comes from the other apps that are using the internet while it is on, so you may try to stop the auto synch on your phone...
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,584 Points 100k badge 2x thumb
if you want to just be able to get picture messages & not use data at all then go into your settings and in you APN settings choose mms only as APN type.
Photo of Dan Nicholson

Dan Nicholson

  • 464 Points 250 badge 2x thumb
I was unable to change to MMS only as it is locked out.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Setting up A Koodo phone for MMS with no additional Data Access
FOR ANDROID DEVICES

Thanks and partial credit to John Burke

Navigate to Settings / Wireless controls / Mobile networks / access point names

You'll be creating two APN's

Add the first apn (usually by hitting the menu key and tapping ADD NEW)

Note: in the example below please omit the spaces between the http: and the address This is done because some websites shorten URL's

Input the following settings (leaving designated fields blank):

APN NAME: Koodo (NoData)
APN: sp.koodo.com
Proxy server:
Port:
Username:
Password:
Server:
MMSC:
Proxy server:
Port:
MCC :
MNC :
APN type :internet

Save this entry (usually by hitting the menu key and selecting SAVE)

Now create a Second APN using the following settings

APN Name: Koodo MMS ALLOW
APN: sp.koodo.com
Proxy server: 74.49.0.18
Port: 80
Username:
Password:
Server:
MMSC: http: //aliasredirect.net/proxy/koodo/mmsc
Proxy server: 74.49.0.18
Port: 80
MCC : 302
MNC : 220
APN type :mms

Now save this entry as you did the first.

On the list of available Access Point Names you'll notice three (or more) entries. Select the Koodo (NoDATA) apn and make it active (you'll notice you can not choose the Koodo MMS ALLOW entry)

Exit the APN menu.

You'll notice the 3G or 4G data indicator has disappeared leaving only the Signal strength indicator. IF YOU HAD PREVIOUSLY TRIED AND FAILED TO SEND PICTURES IT MAY TAKE A FEW MINUTES FOR THE INDICATOR TO DISAPPEAR. When you do send a picture the Data indicator will re-appear and the picture should be sent. Same when you get a picture message.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Right so he will have to create two new ones since he can not edit the original.
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,584 Points 100k badge 2x thumb
Oh didn't think you could create new ones if you couldn't change the other one. Man I gotta get a Koodo locked Android phone, only unlocked devices in my house right now.
Photo of Djenneka

Djenneka

  • 2,122 Points 2k badge 2x thumb
Chad Burr,
Just out of curiosity, Is it possible just to fill the information regarding the mms configuration to be able to send/receive mms only without data? So that would just set phone for mms usage

APN Name: Koodo MMS
APN: sp.koodo.com
Proxy server:
Port:
Username:
Password:
Server:
MMSC: http: //aliasredirect.net/proxy/koodo/mmsc
Proxy server: 74.49.0.18
Port: 80
MCC : 302
MNC : 220
APN type :mms
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,584 Points 100k badge 2x thumb
That's how Ive showed ppl to do it because that's the only way it will work on my factory unlocked international Galaxy Note 2, so yes it works that way
Photo of Dan Nicholson

Dan Nicholson

  • 464 Points 250 badge 2x thumb
Gave that a shot and it didn't work either. Thanks anyway. I appreciate all the suggestions from you folks!
Photo of Dan Nicholson

Dan Nicholson

  • 464 Points 250 badge 2x thumb
Okay, I managed to do all that. And I do check the box that says "enable data access over mobile network."
I suppose if I do want to use some data, I just go back to APN and select Koodo SP ?
In the meantime, I still have 4g symbol and up/down arrows showing up top.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Yes enable data
Make sure you've chosen the new Koodo (no data) apn
The 4g thing should disappear.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
You may also want to reboot
Photo of Dan Nicholson

Dan Nicholson

  • 464 Points 250 badge 2x thumb
When i set up the first APN, it wouldn't allow me to leave MCC and MNC blank. It stated that there had to be 3 digits.
Photo of Marcus Fenix

Marcus Fenix

  • 15,752 Points 10k badge 2x thumb
the MCC and MNC are fine to enter.
Photo of Dan Nicholson

Dan Nicholson

  • 464 Points 250 badge 2x thumb
Well, I tried a reboot, and tried pulling the battery and neither solved the issue. Interesting that when I rebooted, the screen would say "no service" then "Telus" then "Koodo". Nothing to do with it I'm sure.
Anyway, thanks for the help. I'll just have to keep data off. Dan
Photo of Dan Nicholson

Dan Nicholson

  • 464 Points 250 badge 2x thumb
This begs the question, Why wouldn't Koodo have this option available? Seems like a lot of hassle to go through to get my "unlimited text and picture messages." Unless of course they're hoping to get income through accidental data usage.
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,584 Points 100k badge 2x thumb
Your doing something wrong because many other with the Galaxy S2x have reported doing this successfully.
Photo of Dan Nicholson

Dan Nicholson

  • 464 Points 250 badge 2x thumb
I’m willing to keep working at it.
Samsung Galaxy Ace 2 X GT-S7560M Android version 4.04
Pathway Settings-More Settings-Mobile Networks-Access Point Names-Then a list of APN Names
Currently 3 listed:
Koodo (NoData)
Koodo SP
Koodo MMS ALLOW

Koodo SP list is greyed out.
Koodo (NoData):
Name Koodo (NoData)
APN sp.koodo.com
Proxy Not set
Port Not set
Username Not set
Password Not Set
Server Not Set
MMSC Not set
MMS proxy Not set
MMS port Not set
MCC 302
MNC 220
Authentication type Not set
APN Type internet
APN Protocol IPv4 (greyed out)
Enable/disable APN APN enabled (greyed out) and checked off
Bearer Unspecified

Koodo MMS ALLOW:
Name Koodo MMS ALLOW
APN sp.koodo.com
Proxy 74.49.0.18
Port 80
Username Not set
Password Not set
Server Not set
MMSC http://aliasredirect.net/proxy/koodo/...
MMS proxy 74.49.0.18
MS port 80
MCC 302
MNC 220
Authentication type Not set
APN type mms
APN protocol IPv4 (greyed out)
Enable/disable APN APN enabled (greyed out) and checked off
Bearer Unspecified

I entered the data for each of these and saved them. Then I went to Settings-More Settings-Mobile Networks and checked Mobile Data. The 4G icon disappeared but when I turned WIFI off, it reappeared. I rebooted and I saw the name Telus, then Koodo at the top, then the 4G icon returned. Again, when I turned WIFI back on, it disappeared.
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 140,212 Points 100k badge 2x thumb
you can also change the apn for koodo (no data) to spp.koodo.com
Photo of Dan Nicholson

Dan Nicholson

  • 464 Points 250 badge 2x thumb
Okay, we have a winner. Changing to spp seems to be working so far! Thanks very much for all the help folks!
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,584 Points 100k badge 2x thumb
We all need a Timo signal like a bat signal lol the Koodo support guy saves the day yet again, great work Timo (virtual *)
Photo of Dan Nicholson

Dan Nicholson

  • 464 Points 250 badge 2x thumb
How do I give kudos to you guys for all your help today?
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
You just did
Will these setting still allow me to access things like facebook and other online apps while on WiFi and not incur data usage fees?
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
As long as the wifi is connected there's no charge from koodo to use those features. And those features will still function over wifi with these settings enabled.
Photo of No Way

No Way

  • 1,462 Points 1k badge 2x thumb
This has been going on with my phone for months now. I have talk and text and use wireless hotspots. I even have the Internet APn changed so I dont accidently use data. Yet somehow I have between 500-800 kb used a month, which of course is $5

I refuse to have data turned off, as this stops the unlimited MMS they advertise. I dont want to worry about wireless everytime I text.

Why cant koodo fix this, or is this a money grab. 800kb, really??? That isnt data use. and their tech support cant help me saying the pnly way is to block data
Photo of Chris Petersens

Chris Petersens

  • 47,266 Points 20k badge 2x thumb
Can you what uses data in the background? Something is leaking through.
Photo of No Way

No Way

  • 1,462 Points 1k badge 2x thumb
Ive tried, all it says in the data use that Android is doing it, now what app. Hell maybe its the android os itself. I would think editing the Internet APN would be enough. It worked for awhile untl the Andriod os updated a few months ago

This conversation is no longer open for comments or replies.