LTE Coverage in St. John's, Newfoundland

  • 1
  • Question
  • Updated 4 years ago
  • Answered
Hi, I'm living in St. John's, Newfoundland and I have $42 plan with 500MB of data. This location should be under LTE coverage and many of my friends with Koodo have LTE on their iPhones. However my iPhone 5S still says just "3G". The LTE option in Settings is ON. Thank you
Photo of Jan Havlíček

Jan Havlíček

  • 90 Points 75 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Jonathan I

Jonathan I, Mobile Master

  • 114,404 Points 100k badge 2x thumb
Well there's no way it's the SIM card since all Nanos have been LTE since they released...

Try removing the SIM card and shutting down the phone for about a minute, then putting it back in and trying again.

If that doesn't fix it, try resetting network settings (only network settings, not any apps or files). You will lose any saved WiFi passwords.
Photo of Dennis

Dennis, Mobile Master

  • 196,070 Points 100k badge 2x thumb
This is a Koodo iPhone 5s too right?
Photo of Jan Havlíček

Jan Havlíček

  • 90 Points 75 badge 2x thumb
No it's not, it's bought in Europe as brand new phone without any contract, directly from Apple Store
Photo of Jonathan I

Jonathan I, Mobile Master

  • 114,404 Points 100k badge 2x thumb
That may be your issue. It might not have the LTE bands needed for LTE coverage here in Canada. Can you find out the exact model # and cross reference with this:

http://www.apple.com/iphone/LTE/
Photo of Dennis

Dennis, Mobile Master

  • 196,070 Points 100k badge 2x thumb
Jonathan is right. Confident that it's Totally not the right model for Canada LTE
Photo of Jan Havlíček

Jan Havlíček

  • 90 Points 75 badge 2x thumb
Thank you for your reply, you are right. It's model A1457, so it doesn't work with US/CAN LTE
Photo of Jonathan I

Jonathan I, Mobile Master

  • 114,404 Points 100k badge 2x thumb
Ah, we discovered the issue. Sorry, man. At least it's better than not having any service at all!

This conversation is no longer open for comments or replies.